summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/bwm-ng/bwm-ng-0.6.1.ebuild')
-rw-r--r--net-analyzer/bwm-ng/bwm-ng-0.6.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-analyzer/bwm-ng/bwm-ng-0.6.1.ebuild b/net-analyzer/bwm-ng/bwm-ng-0.6.1.ebuild
new file mode 100644
index 000000000000..ae30fbd3d4f7
--- /dev/null
+++ b/net-analyzer/bwm-ng/bwm-ng-0.6.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Bandwidth Monitor NG is a small and simple console-based bandwidth monitor"
+SRC_URI="http://www.gropp.org/bwm-ng/${P}.tar.gz"
+HOMEPAGE="http://www.gropp.org/"
+
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="html csv"
+
+DEPEND="sys-libs/ncurses:0=
+ >=sys-apps/net-tools-1.60-r1"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-buildsystem.patch"
+)
+
+src_prepare() {
+ mv configure.{in,ac} || die
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-ncurses \
+ --with-procnetdev \
+ $(use_enable html) \
+ $(use_enable csv)
+}