summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/chaosreader/chaosreader-0.96.ebuild')
-rw-r--r--net-analyzer/chaosreader/chaosreader-0.96.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-analyzer/chaosreader/chaosreader-0.96.ebuild b/net-analyzer/chaosreader/chaosreader-0.96.ebuild
new file mode 100644
index 000000000000..ab29f713b3df
--- /dev/null
+++ b/net-analyzer/chaosreader/chaosreader-0.96.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Trace TCP/UDP/... sessions and fetch application data."
+HOMEPAGE="http://chaosreader.sourceforge.net
+ https://github.com/brendangregg/Chaosreader"
+SRC_URI="https://github.com/brendangregg/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+LICENSE="GPL-2+"
+
+DEPEND=">=dev-lang/perl-5.8.0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/Chaosreader-${PV}"
+
+PATCHES=(
+ "${FILESDIR}"/chaosreader-0.96-zombies.patch
+ "${FILESDIR}"/chaosreader-0.96-chunkcheck.patch
+ "${FILESDIR}"/chaosreader-0.96-divisionbyzero.patch
+)
+
+src_install() {
+ dobin ${PN}
+}