summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/ettercap')
-rw-r--r--net-analyzer/ettercap/ettercap-0.8.3.1-r3.ebuild (renamed from net-analyzer/ettercap/ettercap-0.8.3.1.ebuild)44
-rw-r--r--net-analyzer/ettercap/ettercap-9999.ebuild42
-rw-r--r--net-analyzer/ettercap/files/ettercap-0.8.3.1-curl-8.patch32
-rw-r--r--net-analyzer/ettercap/files/ettercap-0.8.3.1-libressl.patch36
-rw-r--r--net-analyzer/ettercap/files/ettercap-0.8.3.1-musl.patch39
5 files changed, 161 insertions, 32 deletions
diff --git a/net-analyzer/ettercap/ettercap-0.8.3.1.ebuild b/net-analyzer/ettercap/ettercap-0.8.3.1-r3.ebuild
index 05db91778f2f..2474d2cd615a 100644
--- a/net-analyzer/ettercap/ettercap-0.8.3.1.ebuild
+++ b/net-analyzer/ettercap/ettercap-0.8.3.1-r3.ebuild
@@ -1,17 +1,17 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake
-DESCRIPTION="A suite for man in the middle attacks"
+DESCRIPTION="Suite for man in the middle attacks"
HOMEPAGE="https://github.com/Ettercap/ettercap"
LICENSE="GPL-2+"
SLOT="0"
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == 9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/Ettercap/${PN}.git"
else
@@ -22,15 +22,16 @@ fi
IUSE="doc geoip gtk ipv6 ncurses +plugins test"
RESTRICT="!test? ( test )"
-RDEPEND="dev-libs/libbsd
+RDEPEND="
+ dev-libs/libbsd
dev-libs/libpcre
- dev-libs/openssl:0=
+ dev-libs/openssl:=
net-libs/libnet:1.1
>=net-libs/libpcap-0.8.1
sys-libs/zlib
geoip? ( dev-libs/geoip )
gtk? (
- >=dev-libs/atk-1.2.4
+ >=app-accessibility/at-spi2-core-2.46.0
>=dev-libs/glib-2.2.2:2
media-libs/freetype
x11-libs/cairo
@@ -39,13 +40,25 @@ RDEPEND="dev-libs/libbsd
>=x11-libs/pango-1.2.3
)
ncurses? ( >=sys-libs/ncurses-5.3:= )
- plugins? ( >=net-misc/curl-7.26.0 )"
-DEPEND="${RDEPEND}
- doc? ( app-text/ghostscript-gpl
- sys-apps/groff )
+ plugins? ( >=net-misc/curl-7.26.0 )
+"
+DEPEND="
+ app-alternatives/yacc
+ app-alternatives/lex
+"
+BDEPEND="
+ doc? (
+ app-text/ghostscript-gpl
+ sys-apps/groff
+ )
test? ( dev-libs/check )
- sys-devel/flex
- virtual/yacc"
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-curl-8.patch
+ "${FILESDIR}"/${P}-libressl.patch #903001, 736990
+ "${FILESDIR}"/${P}-musl.patch #897820
+)
src_prepare() {
sed -i "s:Release:Release Gentoo:" CMakeLists.txt || die
@@ -66,8 +79,9 @@ src_configure() {
-DINSTALL_SYSCONFDIR="${EPREFIX}"/etc
)
+ # right now we only support gtk2, but ettercap also supports gtk3
+ # do we care? do we want to support both?
! use gtk && mycmakeargs+=(-DINSTALL_DESKTOP=OFF)
- #right now we only support gtk2, but ettercap also supports gtk3
- #do we care? do we want to support both?
+
cmake_src_configure
}
diff --git a/net-analyzer/ettercap/ettercap-9999.ebuild b/net-analyzer/ettercap/ettercap-9999.ebuild
index 07c3e35f6522..2b82d1fd180f 100644
--- a/net-analyzer/ettercap/ettercap-9999.ebuild
+++ b/net-analyzer/ettercap/ettercap-9999.ebuild
@@ -1,36 +1,37 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake
-DESCRIPTION="A suite for man in the middle attacks"
+DESCRIPTION="Suite for man in the middle attacks"
HOMEPAGE="https://github.com/Ettercap/ettercap"
LICENSE="GPL-2+"
SLOT="0"
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == 9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/Ettercap/${PN}.git"
else
SRC_URI="https://github.com/Ettercap/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+ KEYWORDS="~alpha amd64 arm ppc ppc64 sparc x86"
fi
IUSE="doc geoip gtk ipv6 ncurses +plugins test"
RESTRICT="!test? ( test )"
-RDEPEND="dev-libs/libbsd
- dev-libs/libpcre
- dev-libs/openssl:0=
+RDEPEND="
+ dev-libs/libbsd
+ dev-libs/libpcre2
+ dev-libs/openssl:=
net-libs/libnet:1.1
>=net-libs/libpcap-0.8.1
sys-libs/zlib
geoip? ( dev-libs/geoip )
gtk? (
- >=dev-libs/atk-1.2.4
+ >=app-accessibility/at-spi2-core-2.46.0
>=dev-libs/glib-2.2.2:2
media-libs/freetype
x11-libs/cairo
@@ -39,13 +40,19 @@ RDEPEND="dev-libs/libbsd
>=x11-libs/pango-1.2.3
)
ncurses? ( >=sys-libs/ncurses-5.3:= )
- plugins? ( >=net-misc/curl-7.26.0 )"
-DEPEND="${RDEPEND}
- doc? ( app-text/ghostscript-gpl
- sys-apps/groff )
+ plugins? ( >=net-misc/curl-7.26.0 )
+"
+DEPEND="
+ app-alternatives/yacc
+ app-alternatives/lex
+"
+BDEPEND="
+ doc? (
+ app-text/ghostscript-gpl
+ sys-apps/groff
+ )
test? ( dev-libs/check )
- sys-devel/flex
- virtual/yacc"
+"
src_prepare() {
sed -i "s:Release:Release Gentoo:" CMakeLists.txt || die
@@ -66,8 +73,9 @@ src_configure() {
-DINSTALL_SYSCONFDIR="${EPREFIX}"/etc
)
+ # right now we only support gtk2, but ettercap also supports gtk3
+ # do we care? do we want to support both?
! use gtk && mycmakeargs+=(-DINSTALL_DESKTOP=OFF)
- #right now we only support gtk2, but ettercap also supports gtk3
- #do we care? do we want to support both?
+
cmake_src_configure
}
diff --git a/net-analyzer/ettercap/files/ettercap-0.8.3.1-curl-8.patch b/net-analyzer/ettercap/files/ettercap-0.8.3.1-curl-8.patch
new file mode 100644
index 000000000000..e1c2259733c2
--- /dev/null
+++ b/net-analyzer/ettercap/files/ettercap-0.8.3.1-curl-8.patch
@@ -0,0 +1,32 @@
+https://bugs.gentoo.org/902987
+https://github.com/Ettercap/ettercap/commit/40534662043b7d831d1f6c70448afa9d374a9b63
+
+From 40534662043b7d831d1f6c70448afa9d374a9b63 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Thu, 23 Mar 2023 10:23:14 -0700
+Subject: [PATCH] sslstrip: Enhance the libcurl version check to consider
+ version 8+
+
+Lately curl has released version 8 and hence LIBCURL_VERSION_MAJOR is
+reset to 0, current check assumes major version to be 7 at max and hence
+on systems with libcurl 8+ this check breaks and build fails
+
+Fixes
+
+TOPDIR/build/tmp/work/cortexa15t2hf-neon-yoe-linux-gnueabi/ettercap/0.8.3.1-r0/git/plug-ins/sslstrip/sslstrip.c:57:2: error: libcurl 7.26.0 or up is needed
+ ^
+1 error generated.
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+--- a/plug-ins/sslstrip/sslstrip.c
++++ b/plug-ins/sslstrip/sslstrip.c
+@@ -51,7 +51,7 @@
+
+ #include <curl/curl.h>
+
+-#if (LIBCURL_VERSION_MAJOR < 7) || (LIBCURL_VERSION_MINOR < 26)
++#if (LIBCURL_VERSION_MAJOR < 7) || (LIBCURL_VERSION_MAJOR == 7 && LIBCURL_VERSION_MINOR < 26)
+ #error libcurl 7.26.0 or up is needed
+ #endif
+
+
diff --git a/net-analyzer/ettercap/files/ettercap-0.8.3.1-libressl.patch b/net-analyzer/ettercap/files/ettercap-0.8.3.1-libressl.patch
new file mode 100644
index 000000000000..a56e75c88b75
--- /dev/null
+++ b/net-analyzer/ettercap/files/ettercap-0.8.3.1-libressl.patch
@@ -0,0 +1,36 @@
+https://bugs.gentoo.org/903001
+https://bugs.gentoo.org/736990
+https://github.com/Ettercap/ettercap/pull/1069
+https://github.com/Ettercap/ettercap/commit/b2fc8e959dc71fdbaba08aecb1f157c914490a07
+
+From b2f7634c9dbc0ef68640f0571787d92300e9f9f9 Mon Sep 17 00:00:00 2001
+From: Stefan Strogin <stefan@steils.org>
+Date: Sat, 15 Aug 2020 07:18:31 +0300
+Subject: [PATCH] ec_sslwrap: fix compilation with LibreSSL
+
+Disable taking over SNI extension from ClientHello and SSL configuration
+operations until LibreSSL supports the required API.
+
+Fixes: https://github.com/Ettercap/ettercap/issues/1068
+---
+ src/ec_sslwrap.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/ec_sslwrap.c b/src/ec_sslwrap.c
+index b9f26a142..1e4c24fc1 100644
+--- a/src/ec_sslwrap.c
++++ b/src/ec_sslwrap.c
+@@ -71,11 +71,11 @@
+ #define TLS_server_method SSLv23_server_method
+ #endif
+
+-#if (OPENSSL_VERSION_NUMBER >= 0x10100000L)
++#if (OPENSSL_VERSION_NUMBER >= 0x10100000L) && !defined(LIBRESSL_VERSION_NUMBER)
+ #define HAVE_OPENSSL_1_1_0
+ #endif
+
+-#if (OPENSSL_VERSION_NUMBER >= 0x10101000L)
++#if (OPENSSL_VERSION_NUMBER >= 0x10101000L) && !defined(LIBRESSL_VERSION_NUMBER)
+ #define HAVE_OPENSSL_1_1_1
+ #endif
+
diff --git a/net-analyzer/ettercap/files/ettercap-0.8.3.1-musl.patch b/net-analyzer/ettercap/files/ettercap-0.8.3.1-musl.patch
new file mode 100644
index 000000000000..516823ec6972
--- /dev/null
+++ b/net-analyzer/ettercap/files/ettercap-0.8.3.1-musl.patch
@@ -0,0 +1,39 @@
+Upsream-PR: https://github.com/Ettercap/ettercap/pull/1220
+Uptream-Commit: https://github.com/Ettercap/ettercap/commit/f03a1174ffccf9343423498fa3c65bd9090d4ce0
+Bug: https://bugs.gentoo.org/897820
+
+From 3ef51159d4e2cea97accb87af08943333fbefb04 Mon Sep 17 00:00:00 2001
+From: Gianfranco Costamagna <costamagnagianfranco@yahoo.it>
+Date: Fri, 3 Mar 2023 21:27:14 +0100
+Subject: [PATCH] Define _GNU_SOURCE to make sure memmem is found when musl
+ library is used. This fixes issue: #1219
+
+Thanks Sam James for the suggestion!
+---
+ include/ec.h | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+diff --git a/include/ec.h b/include/ec.h
+index fbf048111..561062c2f 100644
+--- a/include/ec.h
++++ b/include/ec.h
+@@ -21,6 +21,9 @@
+ #if !defined (__USE_GNU) /* for memmem(), strsignal(), etc etc... */
+ #define __USE_GNU
+ #endif
++#if !defined (_GNU_SOURCE) /* for memmem(), strsignal(), etc etc... on musl */
++ #define _GNU_SOURCE
++#endif
+ #ifdef OS_SOLARIS
+ #define _REENTRANT /* for strtok_r() */
+ #endif
+@@ -28,6 +31,9 @@
+ #if defined (__USE_GNU)
+ #undef __USE_GNU
+ #endif
++#if defined (_GNU_SOURCE)
++ #undef _GNU_SOURCE
++#endif
+ #include <strings.h>
+ #include <unistd.h>
+ #include <time.h>