summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/gr-fosphor')
-rw-r--r--net-analyzer/gr-fosphor/Manifest2
-rw-r--r--net-analyzer/gr-fosphor/files/gr-fosphor-0.0_p20200131-htmldir.patch8
-rw-r--r--net-analyzer/gr-fosphor/files/gr-fosphor-0.0_p20210108-fix-use.patch18
-rw-r--r--net-analyzer/gr-fosphor/gr-fosphor-0.0_p20210108.ebuild (renamed from net-analyzer/gr-fosphor/gr-fosphor-0.0_p20200131.ebuild)61
-rw-r--r--net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild61
-rw-r--r--net-analyzer/gr-fosphor/metadata.xml3
6 files changed, 106 insertions, 47 deletions
diff --git a/net-analyzer/gr-fosphor/Manifest b/net-analyzer/gr-fosphor/Manifest
index 7e83ff32c097..d483f1e5b1d9 100644
--- a/net-analyzer/gr-fosphor/Manifest
+++ b/net-analyzer/gr-fosphor/Manifest
@@ -1 +1 @@
-DIST gr-fosphor-0.0_p20200131.tar.gz 244685 BLAKE2B db01b9df87f377db2adaaca3d1542f99eaca9f73303c71ea9add1845307704817c8930736d44462191476b4cb935a18401b7012a1ea6465bdb5cf3624c182f2c SHA512 7bf2758f98ae7d088256060878fbf33966880ddbb7fb132da00f9c2530d84b91a6385eabbf61ff40d3002d3a42eadf5e2d78b8c797bc93501cafaf8a7bdde7ae
+DIST gr-fosphor-0.0_p20210108.tar.gz 223873 BLAKE2B 4c44ea026760a12fbc9f50c439f47b9af3956270d8f0a05c951fb19cc4f23a7064476a0a111d39e79183d52e8c6e686d17bf17f76df92e052f81d8940df588fe SHA512 fa2e4c28f8910eb82de42c76f2c00e8b832c023844f1d61aedb5ef3b0fafa7f3f7f26ab535a936d4ad8a42bedb380e71fe6c03f5e1b767afe731d70e080d241e
diff --git a/net-analyzer/gr-fosphor/files/gr-fosphor-0.0_p20200131-htmldir.patch b/net-analyzer/gr-fosphor/files/gr-fosphor-0.0_p20200131-htmldir.patch
new file mode 100644
index 000000000000..16a4475299bf
--- /dev/null
+++ b/net-analyzer/gr-fosphor/files/gr-fosphor-0.0_p20200131-htmldir.patch
@@ -0,0 +1,8 @@
+--- a/docs/doxygen/CMakeLists.txt
++++ b/docs/doxygen/CMakeLists.txt
+@@ -50,4 +50,4 @@
+
+ add_custom_target(doxygen_target ALL DEPENDS ${BUILT_DIRS})
+
+-install(DIRECTORY ${BUILT_DIRS} DESTINATION ${GR_PKG_DOC_DIR})
++install(DIRECTORY ${BUILT_DIRS} DESTINATION ${CMAKE_INSTALL_DOCDIR})
diff --git a/net-analyzer/gr-fosphor/files/gr-fosphor-0.0_p20210108-fix-use.patch b/net-analyzer/gr-fosphor/files/gr-fosphor-0.0_p20210108-fix-use.patch
new file mode 100644
index 000000000000..da3287f35496
--- /dev/null
+++ b/net-analyzer/gr-fosphor/files/gr-fosphor-0.0_p20210108-fix-use.patch
@@ -0,0 +1,18 @@
+diff --git a/python/bindings/CMakeLists.txt b/python/bindings/CMakeLists.txt
+index b7054da..86e5461 100644
+--- a/python/bindings/CMakeLists.txt
++++ b/python/bindings/CMakeLists.txt
+@@ -54,10 +54,11 @@ endmacro(GR_PYBIND_MAKE)
+
+ list(APPEND fosphor_python_files
+ base_sink_c_python.cc
+- glfw_sink_c_python.cc
+- qt_sink_c_python.cc
+ python_bindings.cc)
+
++list_cond_append(ENABLE_GLFW fosphor_python_files glfw_sink_c_python.cc)
++list_cond_append(ENABLE_QT fosphor_python_files qt_sink_c_python.cc)
++
+ GR_PYBIND_MAKE(fosphor
+ ../..
+ gr::fosphor
diff --git a/net-analyzer/gr-fosphor/gr-fosphor-0.0_p20200131.ebuild b/net-analyzer/gr-fosphor/gr-fosphor-0.0_p20210108.ebuild
index e3c5413176f4..3a6f011748ef 100644
--- a/net-analyzer/gr-fosphor/gr-fosphor-0.0_p20200131.ebuild
+++ b/net-analyzer/gr-fosphor/gr-fosphor-0.0_p20210108.ebuild
@@ -1,53 +1,62 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+EAPI=8
-inherit cmake-utils python-single-r1
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit cmake python-single-r1
DESCRIPTION="gnuradio fosphor block (GPU spectrum display)"
HOMEPAGE="https://sdr.osmocom.org/trac/wiki/fosphor"
-if [[ ${PV} == 9999* ]]; then
+if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/osmocom/${PN}.git"
else
- COMMIT="defdd4aca6cd157ccc3b10ea16b5b4f552f34b96"
+ COMMIT="974ab2fe54c25e8b6c37aa4de148ba0625eef652"
SRC_URI="https://github.com/osmocom/gr-fosphor/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${COMMIT}"
KEYWORDS="~amd64 ~x86"
fi
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
LICENSE="GPL-3+"
SLOT="0"
IUSE="glfw qt5"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RDEPEND="qt5? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtopengl:5
- dev-qt/qtwidgets:5
- )
+RDEPEND="
dev-libs/boost:=
dev-libs/log4cpp
media-libs/freetype
- =net-wireless/gnuradio-3.8*:0=[qt5,${PYTHON_SINGLE_USEDEP}]
+ >=net-wireless/gnuradio-3.9:0=[qt5,${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/pygccxml[${PYTHON_USEDEP}]')
glfw? ( >=media-libs/glfw-3 )
virtual/opencl
virtual/opengl
${PYTHON_DEPS}
-"
-DEPEND="${RDEPEND}
- dev-lang/swig:0
- dev-util/cppunit
-"
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtopengl:5
+ dev-qt/qtwidgets:5
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="$(python_gen_cond_dep 'dev-python/pybind11[${PYTHON_USEDEP}]')"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.0_p20200131-htmldir.patch
+ "${FILESDIR}"/${P}-fix-use.patch )
src_prepare() {
- cmake-utils_src_prepare
- default
+ cmake_src_prepare
+
+ # adapt python bindings to use flags
+ use glfw || sed -i -e "s#bind_glfw_sink_c(m)##" \
+ "${S}"/python/bindings/python_bindings.cc ||die
+ use qt5 || sed -i -e "s#bind_qt_sink_c(m)##" \
+ "${S}"/python/bindings/python_bindings.cc ||die
+
+ eapply_user
}
src_configure() {
@@ -60,5 +69,11 @@ src_configure() {
-DENABLE_QT="$(usex qt5)"
-DENABLE_PYTHON=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ find "${D}" -name '*.py[oc]' -delete || die
+ python_optimize
}
diff --git a/net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild b/net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild
index e3c5413176f4..accf82083f3d 100644
--- a/net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild
+++ b/net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild
@@ -1,53 +1,62 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+EAPI=8
-inherit cmake-utils python-single-r1
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit cmake python-single-r1
DESCRIPTION="gnuradio fosphor block (GPU spectrum display)"
HOMEPAGE="https://sdr.osmocom.org/trac/wiki/fosphor"
-if [[ ${PV} == 9999* ]]; then
+if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/osmocom/${PN}.git"
else
- COMMIT="defdd4aca6cd157ccc3b10ea16b5b4f552f34b96"
+ COMMIT="974ab2fe54c25e8b6c37aa4de148ba0625eef652"
SRC_URI="https://github.com/osmocom/gr-fosphor/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${COMMIT}"
KEYWORDS="~amd64 ~x86"
fi
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
LICENSE="GPL-3+"
SLOT="0"
IUSE="glfw qt5"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RDEPEND="qt5? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtopengl:5
- dev-qt/qtwidgets:5
- )
+RDEPEND="
dev-libs/boost:=
dev-libs/log4cpp
media-libs/freetype
- =net-wireless/gnuradio-3.8*:0=[qt5,${PYTHON_SINGLE_USEDEP}]
+ >=net-wireless/gnuradio-3.9:0=[qt5,${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/pygccxml[${PYTHON_USEDEP}]')
glfw? ( >=media-libs/glfw-3 )
virtual/opencl
virtual/opengl
${PYTHON_DEPS}
-"
-DEPEND="${RDEPEND}
- dev-lang/swig:0
- dev-util/cppunit
-"
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtopengl:5
+ dev-qt/qtwidgets:5
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="$(python_gen_cond_dep 'dev-python/pybind11[${PYTHON_USEDEP}]')"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.0_p20200131-htmldir.patch
+ "${FILESDIR}"/${PN}-0.0_p20210108-fix-use.patch )
src_prepare() {
- cmake-utils_src_prepare
- default
+ cmake_src_prepare
+
+ # adapt python bindings to use flags
+ use glfw || sed -i -e "s#bind_glfw_sink_c(m)##" \
+ "${S}"/python/bindings/python_bindings.cc ||die
+ use qt5 || sed -i -e "s#bind_qt_sink_c(m)##" \
+ "${S}"/python/bindings/python_bindings.cc ||die
+
+ eapply_user
}
src_configure() {
@@ -60,5 +69,11 @@ src_configure() {
-DENABLE_QT="$(usex qt5)"
-DENABLE_PYTHON=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ find "${D}" -name '*.py[oc]' -delete || die
+ python_optimize
}
diff --git a/net-analyzer/gr-fosphor/metadata.xml b/net-analyzer/gr-fosphor/metadata.xml
index e2304ffe68ec..2b496fa3b1f7 100644
--- a/net-analyzer/gr-fosphor/metadata.xml
+++ b/net-analyzer/gr-fosphor/metadata.xml
@@ -8,4 +8,7 @@
<use>
<flag name="glfw">enable GLFW based interface</flag>
</use>
+ <upstream>
+ <remote-id type="github">osmocom/gr-fosphor</remote-id>
+ </upstream>
</pkgmetadata>