summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/hexinject')
-rw-r--r--net-analyzer/hexinject/files/hexinject-1.6-fix-build-system.patch22
-rw-r--r--net-analyzer/hexinject/hexinject-1.6-r2.ebuild (renamed from net-analyzer/hexinject/hexinject-1.6-r1.ebuild)9
2 files changed, 16 insertions, 15 deletions
diff --git a/net-analyzer/hexinject/files/hexinject-1.6-fix-build-system.patch b/net-analyzer/hexinject/files/hexinject-1.6-fix-build-system.patch
index fbe91199bbfa..9d22337afa93 100644
--- a/net-analyzer/hexinject/files/hexinject-1.6-fix-build-system.patch
+++ b/net-analyzer/hexinject/files/hexinject-1.6-fix-build-system.patch
@@ -1,18 +1,22 @@
Author: holgersson <holgersson@posteo.de>
Date: Fri Oct 20 18:30:00 2017 +0200
-Don’t call gcc directly, and respect CFLAGS. As this project
-is plain C I don’t care fore CXXFLAGS here.
+Respect CC, CFLAGS, CPPFLAGS and LDFLAGS.
---- a/Makefile 2017-10-20 18:15:11.743805540 +0200
-+++ b/Makefile 2017-10-20 18:24:55.120009439 +0200
-@@ -1,6 +1,6 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,11 +1,7 @@
-CC = gcc
-CFLAGS = -Wall
-LDFLAGS = -lpcap
-+CC ?= gcc
+CFLAGS += -Wall
-+LDFLAGS = -lpcap
++LDLIBS = -lpcap
- all:
- $(CC) $(CFLAGS) $(LDFLAGS) -o hexinject hexinject.c
+-all:
+- $(CC) $(CFLAGS) $(LDFLAGS) -o hexinject hexinject.c
+- $(CC) $(CFLAGS) $(LDFLAGS) -o prettypacket prettypacket.c
+- $(CC) $(CFLAGS) $(LDFLAGS) -o hex2raw hex2raw.c
++all: hexinject prettypacket hex2raw
+
+ clean:
+ rm -f hexinject prettypacket hex2raw *~
diff --git a/net-analyzer/hexinject/hexinject-1.6-r1.ebuild b/net-analyzer/hexinject/hexinject-1.6-r2.ebuild
index e36c1803461e..bfef01f88b8f 100644
--- a/net-analyzer/hexinject/hexinject-1.6-r1.ebuild
+++ b/net-analyzer/hexinject/hexinject-1.6-r2.ebuild
@@ -1,13 +1,14 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=8
inherit toolchain-funcs
DESCRIPTION="Network packet sniffer and injector"
HOMEPAGE="http://hexinject.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+S="${WORKDIR}/${PN}"
LICENSE="BSD"
SLOT="0"
@@ -18,13 +19,9 @@ DEPEND="net-libs/libpcap"
RDEPEND="${DEPEND}
experimental? ( dev-lang/tcl )"
-S="${WORKDIR}/${PN}"
-
PATCHES=( "${FILESDIR}"/${PN}-1.6-fix-build-system.patch )
src_configure() {
- default
-
tc-export CC
}