summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/ifstat/ifstat-1.1-r2.ebuild')
-rw-r--r--net-analyzer/ifstat/ifstat-1.1-r2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-analyzer/ifstat/ifstat-1.1-r2.ebuild b/net-analyzer/ifstat/ifstat-1.1-r2.ebuild
new file mode 100644
index 000000000000..4005bb857a14
--- /dev/null
+++ b/net-analyzer/ifstat/ifstat-1.1-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools eutils
+
+IUSE="snmp"
+
+DESCRIPTION="Network interface bandwidth usage, with support for snmp targets"
+SRC_URI="http://gael.roualland.free.fr/ifstat/${P}.tar.gz"
+HOMEPAGE="http://gael.roualland.free.fr/ifstat/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha amd64 hppa ~mips ppc ppc64 sparc x86"
+
+DEPEND="snmp? ( >=net-analyzer/net-snmp-5.0 )"
+RDEPEND="${DEPEND}"
+
+DOCS=( HISTORY README TODO )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-make.patch
+ epatch "${FILESDIR}"/${P}-hardened.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with snmp)
+}