summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/ifstatus/ifstatus-2.0.0.ebuild')
-rw-r--r--net-analyzer/ifstatus/ifstatus-2.0.0.ebuild38
1 files changed, 18 insertions, 20 deletions
diff --git a/net-analyzer/ifstatus/ifstatus-2.0.0.ebuild b/net-analyzer/ifstatus/ifstatus-2.0.0.ebuild
index 7b2612d29fee..ff7c23bd9489 100644
--- a/net-analyzer/ifstatus/ifstatus-2.0.0.ebuild
+++ b/net-analyzer/ifstatus/ifstatus-2.0.0.ebuild
@@ -1,32 +1,30 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
inherit toolchain-funcs
-KEYWORDS="~amd64 ~arm ~ppc ~x86"
+DESCRIPTION="Simple CLI program for displaying network statistics in real time"
+HOMEPAGE="https://ifstatus.sourceforge.io/"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${PN}-v${PV}.tar.gz"
+S="${WORKDIR}/${PN}-v${PV}"
-DESCRIPTION="A simple CLI program for displaying network statistics in real time"
-HOMEPAGE="http://ifstatus.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${PN}-v${PV}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
+KEYWORDS="amd64 arm ~ppc ~riscv x86"
+
+RDEPEND=">=sys-libs/ncurses-4.2:0="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
-RDEPEND="
- >=sys-libs/ncurses-4.2:0=
-"
-DEPEND="
- ${RDEPEND}
- virtual/pkgconfig
-"
PATCHES=(
"${FILESDIR}"/${PN}-2.0.0-tinfo.patch
)
-S="${WORKDIR}/${PN}-v${PV}"
src_compile() {
tc-export CXX PKG_CONFIG
- emake GCC=$(tc-getCXX) ${PN}
+ emake GCC="$(tc-getCXX)" ${PN}
}
src_install() {
@@ -35,8 +33,8 @@ src_install() {
}
pkg_postinst() {
- elog "You may want to configure ~/.ifstatus/ifstatus.cfg"
- elog "before running ifstatus. For example, you may add"
- elog "Interfaces = eth0 there. Read the README file for"
- elog "more information."
+ elog "You may want to configure ~/.ifstatus/ifstatus.cfg"
+ elog "before running ifstatus. For example, you may add"
+ elog "Interfaces = eth0 there. Read the README file for"
+ elog "more information."
}