summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/iptraf-ng/iptraf-ng-9999.ebuild')
-rw-r--r--net-analyzer/iptraf-ng/iptraf-ng-9999.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/net-analyzer/iptraf-ng/iptraf-ng-9999.ebuild b/net-analyzer/iptraf-ng/iptraf-ng-9999.ebuild
new file mode 100644
index 000000000000..660a84c6022e
--- /dev/null
+++ b/net-analyzer/iptraf-ng/iptraf-ng-9999.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils git-r3 toolchain-funcs
+
+DESCRIPTION="A console-based network monitoring utility"
+HOMEPAGE="http://fedorahosted.org/iptraf-ng/"
+EGIT_REPO_URI="https://git.fedorahosted.org/git/iptraf-ng.git"
+
+LICENSE="GPL-2 doc? ( FDL-1.1 )"
+SLOT="0"
+KEYWORDS=""
+IUSE="doc"
+
+RESTRICT="test"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.7-r7
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/os-headers
+ !net-analyzer/iptraf
+"
+
+src_prepare() {
+ sed -i \
+ -e '/^CC =/d' \
+ -e '/^CFLAGS/s:= -g -O2:+= :' \
+ -e '/^LDFLAGS =/d' \
+ -e 's|$(QUIET_[[:alpha:]]*)||g' \
+ Makefile || die
+ sed -i \
+ -e 's|IPTRAF|&-NG|g' \
+ -e 's|IPTraf|&-NG|g' \
+ -e 's|iptraf|&-ng|g' \
+ -e 's|rvnamed|&-ng|g' \
+ -e 's|RVNAMED|&-NG|g' \
+ src/*.8 || die
+}
+
+# configure does not do very much we do not already control
+src_configure() { :; }
+
+src_compile() {
+ tc-export CC
+ CFLAGS+=' -DLOCKDIR=\"/run/lock/iptraf-ng\"'
+ default
+}
+
+src_install() {
+ dosbin {iptraf,rvnamed}-ng
+
+ doman src/*.8
+ dodoc AUTHORS CHANGES FAQ README* RELEASE-NOTES
+ use doc && dohtml -a gif,html,png -r Documentation/*
+
+ keepdir /var/{lib,log}/iptraf-ng #376157
+}