summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/iptstate/iptstate-2.2.5.ebuild')
-rw-r--r--net-analyzer/iptstate/iptstate-2.2.5.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-analyzer/iptstate/iptstate-2.2.5.ebuild b/net-analyzer/iptstate/iptstate-2.2.5.ebuild
new file mode 100644
index 000000000000..66712b916b86
--- /dev/null
+++ b/net-analyzer/iptstate/iptstate-2.2.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="IP Tables State displays states being kept by iptables in a top-like format"
+HOMEPAGE="http://www.phildev.net/iptstate/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ~ppc x86"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.7-r7
+ >=net-libs/libnetfilter_conntrack-0.0.50
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ tc-export CXX PKG_CONFIG
+}
+
+src_install() {
+ emake PREFIX="${D}"/usr install
+ dodoc BUGS Changelog CONTRIB README WISHLIST
+}