summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/isic/isic-0.07-r2.ebuild')
-rw-r--r--net-analyzer/isic/isic-0.07-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-analyzer/isic/isic-0.07-r2.ebuild b/net-analyzer/isic/isic-0.07-r2.ebuild
new file mode 100644
index 000000000000..80946f048cc4
--- /dev/null
+++ b/net-analyzer/isic/isic-0.07-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="IP Stack Integrity Checker"
+HOMEPAGE="http://isic.sourceforge.net/"
+SRC_URI="mirror://sourceforge/isic/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+DEPEND="net-libs/libnet:1.1"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ # Add two missing includes
+ echo "#include <netinet/udp.h>" >> isic.h || die
+ echo "#include <netinet/tcp.h>" >> isic.h || die
+
+ # Install man pages in /usr/share/man
+ sed -i -e 's|/man/man1|/share&|g' Makefile.in || die
+}
+
+src_configure() {
+ tc-export CC
+ # Build system does not know about DESTDIR
+ econf --prefix="${D}/usr" --exec_prefix="${D}/usr"
+}