summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/knocker/knocker-0.8.0.ebuild')
-rw-r--r--net-analyzer/knocker/knocker-0.8.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-analyzer/knocker/knocker-0.8.0.ebuild b/net-analyzer/knocker/knocker-0.8.0.ebuild
new file mode 100644
index 000000000000..069f7a174704
--- /dev/null
+++ b/net-analyzer/knocker/knocker-0.8.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Knocker is an easy to use security port scanner written in C"
+HOMEPAGE="https://knocker.sourceforge.net"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.0-fency.patch
+ "${FILESDIR}"/${PN}-0.7.1-knocker_user_is_root.patch
+)
+
+DOCS=( AUTHORS BUGS ChangeLog NEWS README TO-DO )
+
+src_configure() {
+ tc-export CC
+ default
+}