summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/monitoring-plugins/monitoring-plugins-2.3.3-r1.ebuild')
-rw-r--r--net-analyzer/monitoring-plugins/monitoring-plugins-2.3.3-r1.ebuild16
1 files changed, 15 insertions, 1 deletions
diff --git a/net-analyzer/monitoring-plugins/monitoring-plugins-2.3.3-r1.ebuild b/net-analyzer/monitoring-plugins/monitoring-plugins-2.3.3-r1.ebuild
index 555d75dae179..c5b2c08d156d 100644
--- a/net-analyzer/monitoring-plugins/monitoring-plugins-2.3.3-r1.ebuild
+++ b/net-analyzer/monitoring-plugins/monitoring-plugins-2.3.3-r1.ebuild
@@ -3,7 +3,7 @@
EAPI="8"
-inherit flag-o-matic
+inherit autotools flag-o-matic
DESCRIPTION="50+ standard plugins for Icinga, Naemon, Nagios, Shinken, Sensu"
HOMEPAGE="https://www.monitoring-plugins.org/"
@@ -53,6 +53,7 @@ RDEPEND="${DEPEND}
acct-group/nagios
acct-user/nagios
!net-analyzer/nagios-plugins"
+BDEPEND="sys-devel/gettext"
# At least one test is interactive.
RESTRICT="test"
@@ -62,6 +63,19 @@ PATCHES=(
"${FILESDIR}/${PN}-fix-check-http-segfault.patch" #893252
)
+src_prepare() {
+ default
+
+ # Refresh the gettext macro to fix musl build, bug #892645
+ # This should be unnecessary in the next release (>2.3.3) as upstream
+ # refreshed its copy of gnulib, so on next release:
+ # - We may be able to drop the gettext BDEPEND (check!)
+ # - Drop this cp call
+ # - Drop eautoreconf
+ cp "${BROOT}"/usr/share/aclocal/gettext.m4 gl/m4/ || die
+ eautoreconf
+}
+
src_configure() {
append-flags -fno-strict-aliasing