summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/mrtg-ping-probe')
-rw-r--r--net-analyzer/mrtg-ping-probe/Manifest1
-rw-r--r--net-analyzer/mrtg-ping-probe/files/mrtg-ping-cfg84
-rw-r--r--net-analyzer/mrtg-ping-probe/metadata.xml5
-rw-r--r--net-analyzer/mrtg-ping-probe/mrtg-ping-probe-2.2.0.ebuild34
4 files changed, 124 insertions, 0 deletions
diff --git a/net-analyzer/mrtg-ping-probe/Manifest b/net-analyzer/mrtg-ping-probe/Manifest
new file mode 100644
index 000000000000..53203f13b6ab
--- /dev/null
+++ b/net-analyzer/mrtg-ping-probe/Manifest
@@ -0,0 +1 @@
+DIST mrtg-ping-probe-2.2.0.tar.gz 36923 SHA256 2708459c1beb5ab482fa28ff62720f6a2d5707475d40e53a2829927572c96a0e SHA512 efc86ed732547359d8b2d94da367946d8b573e2b4d1b3d240b8eb7c5bfff17971848ad62c1448cdc0305393193d969361328448d9c9b25ae54866f71614b7cea WHIRLPOOL 22efb23198783551bdd65d5f23a5311958865440f78927743509555a5e44b157ed90b55ddfe6e334c02c2938d7b667144e126113eb3d52a610b25746e83f0335
diff --git a/net-analyzer/mrtg-ping-probe/files/mrtg-ping-cfg b/net-analyzer/mrtg-ping-probe/files/mrtg-ping-cfg
new file mode 100644
index 000000000000..85a38221b625
--- /dev/null
+++ b/net-analyzer/mrtg-ping-probe/files/mrtg-ping-cfg
@@ -0,0 +1,84 @@
+#!/bin/sh
+#
+# mrtg-ping-cfg { ping | loss } <device> <"Title of page">
+#
+# This creates the mrtg.cfg configurations to do pings to devices.
+# Makes use of mrt-ping-probe by Peter W. Osel <pwo@guug.de> (see below)
+#
+# leewm@sgp.hp.com
+# Hewlett Packard Singapore
+# IT Site Infrastructure Services
+# modifed by "Molchanov Alexander <xorader@mail.ru>"
+
+# location of mrtg ping probe
+PING_PROBE=/usr/bin/mrtg-ping-probe
+
+if [ $# -ne 3 ]
+then
+ head -n 11 $0
+ exit
+fi
+
+if [ $1 == "ping" ] ; then
+ target="$2.ping"
+ MaxBytes=5000
+ AbsMax=10000
+ Unscaled=""
+ YLegend="Round Trip Time"
+ ShortLegend="ms"
+ Legend1="Maximum Round Trip Time in Milli Second"
+ Legend2="Minimum Round Trip Time in Milli Second"
+ Legend3="Maximal 5 Minute Maximum Round Trip Time"
+ Legend4="Maximal 5 Minute Minimum Round Trip Time"
+ LegendI="&nbsp;Max:"
+ LegendO="&nbsp;Min:"
+ PageTop="<H1>$3</H1><P>Actually we are measuring the ping time between our web server and $2."
+elif [ $1 == "loss" ] ; then
+ target="$2.loss"
+ PING_PROBE="$PING_PROBE -p loss/loss"
+ MaxBytes=100
+ AbsMax=101
+ Unscaled="Unscaled[$target]: dwmy"
+ YLegend="% Packet Loss"
+ ShortLegend="%"
+ Legend1="% Packet Loss"
+ Legend2="% Packet Loss"
+ Legend3="Maximal 5 Minute % Packet Loss"
+ Legend4="Maximal 5 Minute % Packet Loss"
+ LegendI="&nbsp;% loss:"
+ LegendO="&nbsp;% loss:"
+ PageTop="<H1>$3</H1><P>Actually we are packet loss between our web server and $2."
+else
+ echo "enter first argument 'ping' or 'loss'" >&2
+ head -n 11 $0
+ exit
+fi
+
+cat <<EOF
+#############################################################
+# $1 stats for $2
+# $3
+
+Title[$target]: $3
+MaxBytes[$target]: $MaxBytes
+AbsMax[$target]: $AbsMax
+Options[$target]: gauge
+Target[$target]: \`$PING_PROBE $2\`
+PageTop[$target]: $PageTop
+YLegend[$target]: $YLegend
+ShortLegend[$target]: $ShortLegend
+Legend1[$target]: $Legend1
+Legend2[$target]: $Legend2
+Legend3[$target]: $Legend3
+Legend4[$target]: $Legend4
+LegendI[$target]: $LegendI
+LegendO[$target]: $LegendO
+WithPeak[$target]: ymwd
+$Unscaled
+
+#-------------------------------------------------------------------
+
+EOF
+
+exit
+
diff --git a/net-analyzer/mrtg-ping-probe/metadata.xml b/net-analyzer/mrtg-ping-probe/metadata.xml
new file mode 100644
index 000000000000..03aa50bab7e3
--- /dev/null
+++ b/net-analyzer/mrtg-ping-probe/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+</pkgmetadata>
diff --git a/net-analyzer/mrtg-ping-probe/mrtg-ping-probe-2.2.0.ebuild b/net-analyzer/mrtg-ping-probe/mrtg-ping-probe-2.2.0.ebuild
new file mode 100644
index 000000000000..0aeab8cc23e0
--- /dev/null
+++ b/net-analyzer/mrtg-ping-probe/mrtg-ping-probe-2.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Addon mrtg contrib for stats ping/loss packets"
+SRC_URI="ftp://ftp.pwo.de/pub/pwo/mrtg/${PN}/${P}.tar.gz"
+HOMEPAGE="http://pwo.de/projects/mrtg/"
+
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="dev-lang/perl"
+RDEPEND="
+ ${DEPEND}
+ net-analyzer/mrtg
+"
+
+src_prepare() {
+ sed -i check-ping-fmt \
+ -e 's:#!/usr/local/bin/perl -w:#!/usr/bin/perl -w:' \
+ || die
+ sed -i mrtg-ping-probe \
+ -e 's:#!/bin/perl:#!/usr/bin/perl:' \
+ || die
+}
+
+src_install () {
+ dodoc ChangeLog NEWS README TODO mrtg.cfg-ping
+ doman mrtg-ping-probe.1
+ dobin check-ping-fmt mrtg-ping-probe "${FILESDIR}"/mrtg-ping-cfg
+}