summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/mtr/mtr-9999.ebuild')
-rw-r--r--net-analyzer/mtr/mtr-9999.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/net-analyzer/mtr/mtr-9999.ebuild b/net-analyzer/mtr/mtr-9999.ebuild
index 7067fbb688f5..bf0d00068f92 100644
--- a/net-analyzer/mtr/mtr-9999.ebuild
+++ b/net-analyzer/mtr/mtr-9999.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit autotools bash-completion-r1 fcaps git-r3
DESCRIPTION="My TraceRoute, an Excellent network diagnostic tool"
@@ -10,8 +11,9 @@ EGIT_REPO_URI="https://github.com/traviscross/mtr"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
IUSE="gtk +ipinfo +ipv6 jansson ncurses"
+# TODO: This is an inherited RESTRICT - figure out why!
+RESTRICT="test"
RDEPEND="
gtk? (
@@ -21,18 +23,15 @@ RDEPEND="
jansson? ( dev-libs/jansson )
ncurses? ( sys-libs/ncurses:0= )
"
-DEPEND="
- ${RDEPEND}
-"
-BDEPEND="
- virtual/pkgconfig
-"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
DOCS=( AUTHORS FORMATS NEWS README.md SECURITY TODO )
FILECAPS=( cap_net_raw usr/sbin/mtr-packet )
+
PATCHES=(
"${FILESDIR}"/${PN}-0.88-tinfo.patch
)
-RESTRICT="test"
src_prepare() {
default