summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nagios-check_glsa2/nagios-check_glsa2-20120930-r1.ebuild')
-rw-r--r--net-analyzer/nagios-check_glsa2/nagios-check_glsa2-20120930-r1.ebuild35
1 files changed, 14 insertions, 21 deletions
diff --git a/net-analyzer/nagios-check_glsa2/nagios-check_glsa2-20120930-r1.ebuild b/net-analyzer/nagios-check_glsa2/nagios-check_glsa2-20120930-r1.ebuild
index 5b6ab2dd057a..aba3bf1143f7 100644
--- a/net-analyzer/nagios-check_glsa2/nagios-check_glsa2-20120930-r1.ebuild
+++ b/net-analyzer/nagios-check_glsa2/nagios-check_glsa2-20120930-r1.ebuild
@@ -1,38 +1,31 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-
-inherit multilib user
-
-DESCRIPTION="Nagios check script for GLSAs (Gentoo Linux Security Advisories)"
-HOMEPAGE="https://github.com/craig/check_glsa2"
+EAPI=7
MY_PN="${PN/nagios-/}"
MY_P="${MY_PN}-${PV}"
-S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Nagios check script for GLSAs (Gentoo Linux Security Advisories)"
+HOMEPAGE="https://github.com/craig/check_glsa2"
SRC_URI="https://dev.gentoo.org/~flameeyes/${MY_PN}/${MY_P}.tar.xz"
+
LICENSE="GPL-2 BSD-2"
SLOT="0"
-
KEYWORDS="amd64"
-RDEPEND="app-portage/gentoolkit"
-DEPEND=""
-
-pkg_setup() {
- enewgroup nagios
- enewuser nagios -1 /bin/bash /dev/null nagios
-}
+DEPEND="
+ acct-group/nagios
+ acct-user/nagios"
+RDEPEND="
+ ${DEPEND}
+ app-portage/gentoolkit"
-src_prepare() {
- sed -i -e '/CACHEDIR=/s:=.*:=/var/cache/check_glsa2:' ${MY_PN}_cached.sh || die
-}
+S="${WORKDIR}/${MY_P}"
+PATCHES=( "${FILESDIR}"/${PN}-20120930-CACHEDIR.patch )
src_install() {
- local nagiosplugindir=/usr/$(get_libdir)/nagios/plugins
- exeinto ${nagiosplugindir}
+ exeinto /usr/$(get_libdir)/nagios/plugins
doexe *.sh
dodoc README