summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/netdiscover/netdiscover-0.7.ebuild')
-rw-r--r--net-analyzer/netdiscover/netdiscover-0.7.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-analyzer/netdiscover/netdiscover-0.7.ebuild b/net-analyzer/netdiscover/netdiscover-0.7.ebuild
new file mode 100644
index 000000000000..b48c92e92656
--- /dev/null
+++ b/net-analyzer/netdiscover/netdiscover-0.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Active/passive address reconnaissance tool"
+HOMEPAGE="https://github.com/netdiscover-scanner/netdiscover"
+SRC_URI="
+ https://github.com/${PN}-scanner/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+"
+S="${WORKDIR}/${P/_/-}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=net-libs/libpcap-0.8.3-r1
+"
+RDEPEND="
+ ${DEPEND}
+"
+DOCS=( AUTHORS ChangeLog README TODO )
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ append-cflags -fcommon
+ default
+}