summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nettop/nettop-0.2.3-r2.ebuild')
-rw-r--r--net-analyzer/nettop/nettop-0.2.3-r2.ebuild36
1 files changed, 21 insertions, 15 deletions
diff --git a/net-analyzer/nettop/nettop-0.2.3-r2.ebuild b/net-analyzer/nettop/nettop-0.2.3-r2.ebuild
index 9f5605fa16a6..b77fcdc473e8 100644
--- a/net-analyzer/nettop/nettop-0.2.3-r2.ebuild
+++ b/net-analyzer/nettop/nettop-0.2.3-r2.ebuild
@@ -1,32 +1,38 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=8
-inherit eutils toolchain-funcs
+inherit autotools toolchain-funcs
-DESCRIPTION="top like program for network activity"
-SRC_URI="mirror://gentoo/${P}.tar.gz"
+DESCRIPTION="top-like program for network activity"
HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
-SLOT="0"
LICENSE="BSD"
-KEYWORDS="amd64 ~arm ppc x86"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ppc x86"
-DEPEND="
+RDEPEND="
sys-libs/slang
- net-libs/libpcap
-"
-RDEPEND="${DEPEND}"
+ net-libs/libpcap"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc411.patch
+ "${FILESDIR}"/${P}-offbyone.patch
+)
src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-gcc411.patch \
- "${FILESDIR}"/${P}-offbyone.patch
+ default
+
+ eautoreconf #871408
+ sed -i 's/configure.in/configure.ac/' Makefile.in || die
+
tc-export CC
}
src_install() {
dosbin nettop
- dodoc ChangeLog README THANKS
+ einstalldocs
}