summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nfdump/nfdump-1.6.16-r1.ebuild')
-rw-r--r--net-analyzer/nfdump/nfdump-1.6.16-r1.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/net-analyzer/nfdump/nfdump-1.6.16-r1.ebuild b/net-analyzer/nfdump/nfdump-1.6.16-r1.ebuild
deleted file mode 100644
index 1c1536dcf588..000000000000
--- a/net-analyzer/nfdump/nfdump-1.6.16-r1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit autotools eutils ltprune
-
-DESCRIPTION="A set of tools to collect and process netflow data"
-HOMEPAGE="https://github.com/phaag/nfdump"
-SRC_URI="https://github.com/phaag/nfdump/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/1.6.15"
-KEYWORDS="~amd64 ~x86"
-IUSE="compat15 debug ftconv nfprofile nftrack readpcap sflow static-libs"
-
-COMMON_DEPEND="
- app-arch/bzip2
- sys-libs/zlib
- ftconv? ( sys-libs/zlib net-analyzer/flow-tools )
- nfprofile? ( net-analyzer/rrdtool )
- nftrack? ( net-analyzer/rrdtool )
- readpcap? ( net-libs/libpcap )
-"
-DEPEND="
- ${COMMON_DEPEND}
- sys-devel/flex
- virtual/yacc
-"
-RDEPEND="
- ${COMMON_DEPEND}
- dev-lang/perl
-"
-DOCS=( AUTHORS ChangeLog README.md )
-PATCHES=(
- "${FILESDIR}"/${PN}-1.6.14-libft.patch
- "${FILESDIR}"/${PN}-1.6.16-libnfdump.patch
- "${FILESDIR}"/${PN}-1.6.16-DEVEL.patch
-)
-
-src_prepare() {
- default
-
- eautoreconf
-}
-
-src_configure() {
- # --without-ftconf is not handled well #322201
- econf \
- $(use ftconv && echo "--enable-ftconv --with-ftpath=/usr") \
- $(use nfprofile && echo --enable-nfprofile) \
- $(use nftrack && echo --enable-nftrack) \
- $(use_enable compat15) \
- $(use_enable debug devel) \
- $(use_enable readpcap) \
- $(use_enable sflow) \
- $(use_enable static-libs static)
-}
-
-src_install() {
- default
-
- prune_libtool_files
-}