summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nikto/nikto-1.36.ebuild')
-rw-r--r--net-analyzer/nikto/nikto-1.36.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/net-analyzer/nikto/nikto-1.36.ebuild b/net-analyzer/nikto/nikto-1.36.ebuild
new file mode 100644
index 000000000000..be40238112e1
--- /dev/null
+++ b/net-analyzer/nikto/nikto-1.36.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Web Server vulnerability scanner"
+HOMEPAGE="http://www.cirt.net/Nikto2"
+SRC_URI="http://www.cirt.net/source/nikto/ARCHIVE/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc sparc x86"
+RDEPEND="dev-lang/perl
+ >=net-analyzer/nmap-3.00
+ ssl? ( dev-libs/openssl )"
+IUSE="ssl"
+
+src_compile() {
+ sed -i -e 's:config.txt:nikto.conf:' \
+ -i -e 's:\$CFG{configfile}="nikto.conf":\$CFG{configfile}="/etc/nikto/nikto.conf":' \
+ nikto.pl
+
+ mv config.txt nikto.conf
+
+ sed -i -e 's:^#NMAP:NMAP:' \
+ -i -e 's:^PROXYHOST:#PROXYHOST:' \
+ -i -e 's:^PROXYPORT:#PROXYPORT:' \
+ -i -e 's:^PROXYUSER:#PROXYUSER:' \
+ -i -e 's:^PROXYPASS:#PROXYPASS:' \
+ -i -e 's:# PLUGINDIR=/usr/local/nikto/plugins:PLUGINDIR=/usr/share/nikto/plugins:' \
+ nikto.conf
+
+ cp "${S}/docs/nikto-${PV}.man" "${WORKDIR}/${PN}.1"
+}
+
+src_install() {
+ insinto /etc/nikto
+ doins nikto.conf
+
+ dodir /usr/bin
+ dobin nikto.pl
+ dosym /usr/bin/nikto.pl /usr/bin/nikto
+
+ dodir /usr/share/nikto/plugins
+ insinto /usr/share/nikto/plugins
+ doins plugins/*
+
+ cd docs
+ dodoc CHANGES.txt LICENSE.txt README_plugins.txt nikto_usage.txt
+ dohtml nikto_usage.html
+ doman "${WORKDIR}/${PN}.1"
+}