summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/odhcploc/odhcploc-20111021-r2.ebuild')
-rw-r--r--net-analyzer/odhcploc/odhcploc-20111021-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-analyzer/odhcploc/odhcploc-20111021-r2.ebuild b/net-analyzer/odhcploc/odhcploc-20111021-r2.ebuild
new file mode 100644
index 000000000000..c3f0850644e0
--- /dev/null
+++ b/net-analyzer/odhcploc/odhcploc-20111021-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Open DHCP Locator"
+HOMEPAGE="http://odhcploc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_configure() {
+ # Don't clobber toolchain defaults
+ sed -i -e 's:-Wp,-D_FORTIFY_SOURCE=2::' Makefile || die
+
+ tc-export CC
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.8
+ dodoc AUTHORS
+}