summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/ospd/ospd-2.0.0-r1.ebuild')
-rw-r--r--net-analyzer/ospd/ospd-2.0.0-r1.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/net-analyzer/ospd/ospd-2.0.0-r1.ebuild b/net-analyzer/ospd/ospd-2.0.0-r1.ebuild
deleted file mode 100644
index d6eb8b8a8dff..000000000000
--- a/net-analyzer/ospd/ospd-2.0.0-r1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-inherit distutils-r1
-
-DESCRIPTION="Base class for scanner wrappers,communication protocol for GVM"
-HOMEPAGE="https://www.greenbone.net/en/"
-SRC_URI="https://github.com/greenbone/ospd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-IUSE="extras"
-
-RDEPEND="
- dev-python/defusedxml[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/paramiko[${PYTHON_USEDEP}]"
-
-DEPEND="
- ${RDEPEND}"
-
-PATCHES=(
- # fixes socket permissions see https://github.com/greenbone/ospd-openvas/issues/170
- "${FILESDIR}/${P}-socket-permission.patch"
-)
-
-distutils_enable_tests unittest
-
-python_compile() {
- if use extras; then
- bash "${S}"/doc/generate || die
- HTML_DOCS=( "${S}"/doc/. )
- fi
- distutils-r1_python_compile
-}