summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/ospd/ospd-2.0.0.ebuild')
-rw-r--r--net-analyzer/ospd/ospd-2.0.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-analyzer/ospd/ospd-2.0.0.ebuild b/net-analyzer/ospd/ospd-2.0.0.ebuild
new file mode 100644
index 000000000000..ae035362d7db
--- /dev/null
+++ b/net-analyzer/ospd/ospd-2.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Base class for scanner wrappers,communication protocol for GVM"
+HOMEPAGE="https://www.greenbone.net/en/"
+SRC_URI="https://github.com/greenbone/ospd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="extras"
+
+RDEPEND="
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}"
+
+python_compile() {
+ if use extras; then
+ bash "${S}"/doc/generate || die
+ HTML_DOCS=( "${S}"/doc/. )
+ fi
+ distutils-r1_python_compile
+}