summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/pypacker/pypacker-4.7.ebuild')
-rw-r--r--net-analyzer/pypacker/pypacker-4.7.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-analyzer/pypacker/pypacker-4.7.ebuild b/net-analyzer/pypacker/pypacker-4.7.ebuild
new file mode 100644
index 000000000000..7c4a61cdce42
--- /dev/null
+++ b/net-analyzer/pypacker/pypacker-4.7.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{5,6} )
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Fast and simple packet creation and parsing library for Python"
+HOMEPAGE="https://gitlab.com/mike01/pypacker"
+SRC_URI="${HOMEPAGE}/-/archive/v${PV}/pypacker-v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( AUTHORS CHANGES HACKING README.md )
+
+python_test() {
+ "${PYTHON}" tests/test_pypacker.py || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use examples && dodoc -r examples
+}