summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/python-gvm/python-gvm-21.11.0.ebuild')
-rw-r--r--net-analyzer/python-gvm/python-gvm-21.11.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-analyzer/python-gvm/python-gvm-21.11.0.ebuild b/net-analyzer/python-gvm/python-gvm-21.11.0.ebuild
new file mode 100644
index 000000000000..b50a5c454cd0
--- /dev/null
+++ b/net-analyzer/python-gvm/python-gvm-21.11.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+
+inherit distutils-r1
+
+DESCRIPTION="Greenbone Vulnerability Management Python Library"
+HOMEPAGE="https://www.greenbone.net/en/ https://github.com/greenbone/python-gvm/"
+SRC_URI="https://github.com/greenbone/python-gvm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest