summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/python-gvm')
-rw-r--r--net-analyzer/python-gvm/Manifest1
-rw-r--r--net-analyzer/python-gvm/metadata.xml21
-rw-r--r--net-analyzer/python-gvm/python-gvm-1.1.0.ebuild35
3 files changed, 57 insertions, 0 deletions
diff --git a/net-analyzer/python-gvm/Manifest b/net-analyzer/python-gvm/Manifest
new file mode 100644
index 000000000000..6f471dca1626
--- /dev/null
+++ b/net-analyzer/python-gvm/Manifest
@@ -0,0 +1 @@
+DIST python-gvm-1.1.0.tar.gz 160289 BLAKE2B 64dbf79f6749c50cddc2b908c45c6aea6c3793f0ddb10a98a96870636ee351f1a2e66227fbcc1383c63e0e015b4c05bf4c116ac80ef35f73f7e9057f9c8dd9b5 SHA512 dae04d42a14adde274c2148f7bd4b47b0ea02d6e249d6c23dfeb15f217f04ad9ff722f2e98d13e1a7add7b61d9dabfec623ab5b45087aaf5f480447fd31a8071
diff --git a/net-analyzer/python-gvm/metadata.xml b/net-analyzer/python-gvm/metadata.xml
new file mode 100644
index 000000000000..92109f9a1354
--- /dev/null
+++ b/net-analyzer/python-gvm/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>hasan.calisir@psauxit.com</email>
+ <name>Hasan ÇALIŞIR</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ The Greenbone Vulnerability Management Python API library (python-gvm) is a collection of
+ APIs that help with remote controlling a Greenbone Security Manager (GSM) appliance and its
+ underlying Greenbone Vulnerability Manager (GVM). The library essentially abstracts accessing
+ the communication protocols Greenbone Management Protocol (GMP) and Open Scanner Protocol (OSP).
+ </longdescription>
+ <upstream>
+ <remote-id type="github">greenbone/python-gvm</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-analyzer/python-gvm/python-gvm-1.1.0.ebuild b/net-analyzer/python-gvm/python-gvm-1.1.0.ebuild
new file mode 100644
index 000000000000..337868c6e65a
--- /dev/null
+++ b/net-analyzer/python-gvm/python-gvm-1.1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Greenbone Vulnerability Management Python Library"
+HOMEPAGE="https://www.greenbone.net/en/"
+SRC_URI="https://github.com/greenbone/python-gvm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}"
+
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ distutils-r1_python_prepare_all
+ # Exlude tests & docs to fix build issue
+ sed \
+ -e "s/packages=find_packages(exclude=.*/packages=find_packages(exclude=['tests*', 'docs']),/g" \
+ -i "$S"/setup.py || die
+}