summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/rtpbreak/rtpbreak-1.3a-r2.ebuild')
-rw-r--r--net-analyzer/rtpbreak/rtpbreak-1.3a-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-analyzer/rtpbreak/rtpbreak-1.3a-r2.ebuild b/net-analyzer/rtpbreak/rtpbreak-1.3a-r2.ebuild
new file mode 100644
index 000000000000..bdd5d139be1b
--- /dev/null
+++ b/net-analyzer/rtpbreak/rtpbreak-1.3a-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Analyze any RTP session through heuristics over UDP network traffic"
+HOMEPAGE="http://xenion.reactive-search.com/?page_id=7"
+SRC_URI="http://xenion.antifork.org/rtpbreak/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="net-libs/libnet:1.1
+ >=net-libs/libpcap-0.7"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-limits.patch
+ "${FILESDIR}"/${P}-missing-headers.patch
+)
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin src/rtpbreak
+ einstalldocs
+ dodoc -r doc
+}