summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/scanlogd/scanlogd-2.2.7-r1.ebuild')
-rw-r--r--net-analyzer/scanlogd/scanlogd-2.2.7-r1.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/net-analyzer/scanlogd/scanlogd-2.2.7-r1.ebuild b/net-analyzer/scanlogd/scanlogd-2.2.7-r1.ebuild
deleted file mode 100644
index 425d76c6c154..000000000000
--- a/net-analyzer/scanlogd/scanlogd-2.2.7-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit savedconfig toolchain-funcs
-
-DESCRIPTION="A port scan detection tool"
-SRC_URI="http://www.openwall.com/scanlogd/${P}.tar.gz"
-HOMEPAGE="http://www.openwall.com/scanlogd/"
-
-LICENSE="scanlogd GPL-2" # GPL-2 for initscript
-SLOT="0"
-KEYWORDS="~amd64 ~ppc x86"
-IUSE="+nids pcap"
-REQUIRED_USE="?? ( nids pcap )"
-
-DEPEND="
- nids? ( net-libs/libnids )
- pcap? ( net-libs/libpcap )
-"
-RDEPEND="
- ${DEPEND}
- acct-group/scanlogd
- acct-user/scanlogd
-"
-
-PATCHES=(
- "${FILESDIR}"/${P}-gentoo.patch
-)
-
-src_prepare() {
- default
- restore_config params.h
- tc-export CC
-}
-
-src_compile() {
- local target=linux
- use nids && target=libnids
- use pcap && target=libpcap
- emake ${target}
-}
-
-src_install() {
- dosbin scanlogd
- doman scanlogd.8
- newinitd "${FILESDIR}"/scanlogd.rc scanlogd
- save_config params.h
-}