summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/scanlogd/scanlogd-2.2.8-r1.ebuild')
-rw-r--r--net-analyzer/scanlogd/scanlogd-2.2.8-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/net-analyzer/scanlogd/scanlogd-2.2.8-r1.ebuild b/net-analyzer/scanlogd/scanlogd-2.2.8-r1.ebuild
new file mode 100644
index 000000000000..c4c0611a002a
--- /dev/null
+++ b/net-analyzer/scanlogd/scanlogd-2.2.8-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit savedconfig toolchain-funcs
+
+DESCRIPTION="A port scan detection tool"
+SRC_URI="https://www.openwall.com/scanlogd/${P}.tar.gz"
+HOMEPAGE="https://www.openwall.com/scanlogd/"
+
+LICENSE="scanlogd GPL-2" # GPL-2 for initscript
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE="+nids pcap"
+REQUIRED_USE="?? ( nids pcap )"
+
+DEPEND="
+ nids? ( net-libs/libnids )
+ pcap? ( net-libs/libpcap )
+"
+RDEPEND="
+ ${DEPEND}
+ acct-group/scanlogd
+ acct-user/scanlogd
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.2.7-gentoo.patch
+)
+
+src_prepare() {
+ default
+
+ restore_config params.h
+
+ tc-export CC
+}
+
+src_compile() {
+ local target=linux
+
+ use nids && target=libnids
+ use pcap && target=libpcap
+ emake ${target}
+}
+
+src_install() {
+ dosbin scanlogd
+
+ doman scanlogd.8
+ newinitd "${FILESDIR}"/scanlogd.rc scanlogd
+
+ save_config params.h
+}