summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/slurm')
-rw-r--r--net-analyzer/slurm/files/slurm-0.4.3-fix-includes.patch22
-rw-r--r--net-analyzer/slurm/slurm-0.4.3.ebuild34
2 files changed, 36 insertions, 20 deletions
diff --git a/net-analyzer/slurm/files/slurm-0.4.3-fix-includes.patch b/net-analyzer/slurm/files/slurm-0.4.3-fix-includes.patch
new file mode 100644
index 000000000000..9e933ffc509c
--- /dev/null
+++ b/net-analyzer/slurm/files/slurm-0.4.3-fix-includes.patch
@@ -0,0 +1,22 @@
+--- a/os.h
++++ b/os.h
+@@ -177,7 +177,7 @@
+ #elif defined (__linux__) /* L I N U X */
+ #include <stdio.h>
+ #include <sys/param.h>
+-#include <sys/sysctl.h>
++#include <linux/sysctl.h>
+ #include <stdlib.h>
+ #include <stdarg.h>
+ #include <unistd.h>
+@@ -195,8 +195,8 @@
+ #include <netinet/in.h>
+ #include <net/if.h>
+ #include <arpa/inet.h>
+-#include <net/ppp_defs.h>
+-#include <net/if_ppp.h>
++#include <linux/ppp_defs.h>
++#include <linux/if_ppp.h>
+ #elif defined (__Solaris__) /* S O L A R I S */
+ #include <stdio.h>
+ #define NO_CURSES_E 1
diff --git a/net-analyzer/slurm/slurm-0.4.3.ebuild b/net-analyzer/slurm/slurm-0.4.3.ebuild
index 95641beb1b22..da86bb68d8bf 100644
--- a/net-analyzer/slurm/slurm-0.4.3.ebuild
+++ b/net-analyzer/slurm/slurm-0.4.3.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit cmake-utils
+EAPI=7
+
+inherit cmake
DESCRIPTION="Realtime network interface monitor based on FreeBSD's pppstatus"
HOMEPAGE="https://github.com/mattthias/slurm"
@@ -12,26 +13,19 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-RDEPEND="
- sys-libs/ncurses:*
-"
-DEPEND="
- ${RDEPEND}
-"
+RDEPEND="sys-libs/ncurses:="
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}-upstream"
+
PATCHES=(
"${FILESDIR}"/${PN}-0.3.3-overflow.patch
"${FILESDIR}"/${P}-tinfo.patch
"${FILESDIR}"/${P}-version.patch
-)
-DOCS=(
- AUTHORS
- ChangeLog
- FAQ
- KEYS
- README
- THANKS
- THEMES.txt
- TODO
+ "${FILESDIR}"/${P}-fix-includes.patch
)
-S=${WORKDIR}/${PN}-upstream
+src_install() {
+ cmake_src_install
+ dodoc KEYS THEMES.txt
+}