summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/speedtest-cli/speedtest-cli-2.1.2-r1.ebuild')
-rw-r--r--net-analyzer/speedtest-cli/speedtest-cli-2.1.2-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-analyzer/speedtest-cli/speedtest-cli-2.1.2-r1.ebuild b/net-analyzer/speedtest-cli/speedtest-cli-2.1.2-r1.ebuild
new file mode 100644
index 000000000000..adbeae7674b3
--- /dev/null
+++ b/net-analyzer/speedtest-cli/speedtest-cli-2.1.2-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Command line interface for testing internet bandwidth using speedtest.net"
+HOMEPAGE="https://github.com/sivel/speedtest-cli"
+SRC_URI="https://github.com/sivel/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ppc ppc64 x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+DOCS=( CONTRIBUTING.md README.rst )
+
+python_install_all() {
+ doman ${PN}.1
+ distutils-r1_python_install_all
+}