summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/synscan/synscan-5.01.ebuild')
-rw-r--r--net-analyzer/synscan/synscan-5.01.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-analyzer/synscan/synscan-5.01.ebuild b/net-analyzer/synscan/synscan-5.01.ebuild
new file mode 100644
index 000000000000..b4a11c7ca7df
--- /dev/null
+++ b/net-analyzer/synscan/synscan-5.01.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="A fast asynchronous half-open TCP portscanner"
+HOMEPAGE="http://www.digit-labs.org/files/tools/synscan/"
+SRC_URI="http://www.digit-labs.org/files/tools/${PN}/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="kernel_FreeBSD kernel_linux"
+
+RDEPEND="net-libs/libpcap"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+ eautoconf
+}
+
+src_compile() {
+ local _target
+ use kernel_FreeBSD && _target=freebsd
+ use kernel_linux && _target=linux
+
+ emake ${_target}
+}
+
+src_install() {
+ dobin synscan sslog
+ dodoc AUTHORS README
+}