summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/tsung/tsung-1.8.0.ebuild')
-rw-r--r--net-analyzer/tsung/tsung-1.8.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-analyzer/tsung/tsung-1.8.0.ebuild b/net-analyzer/tsung/tsung-1.8.0.ebuild
new file mode 100644
index 000000000000..fbee6e966333
--- /dev/null
+++ b/net-analyzer/tsung/tsung-1.8.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+# Seems to be misconfigured
+RESTRICT="test"
+
+DESCRIPTION="Erlang's multi-protocol distributed load testing tool"
+HOMEPAGE="http://tsung.erlang-projects.org/"
+SRC_URI="http://tsung.erlang-projects.org/dist/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnuplot"
+
+DEPEND="dev-lang/erlang"
+RDEPEND="
+ gnuplot? (
+ sci-visualization/gnuplot
+ dev-perl/Template-Toolkit
+ )
+ ${DEPEND}
+"
+src_configure() {
+ ./configure --prefix="/usr" || die "econf failed"
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+}