summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/wapiti')
-rw-r--r--net-analyzer/wapiti/Manifest2
-rw-r--r--net-analyzer/wapiti/wapiti-3.0.5.ebuild43
-rw-r--r--net-analyzer/wapiti/wapiti-3.1.2.ebuild51
3 files changed, 0 insertions, 96 deletions
diff --git a/net-analyzer/wapiti/Manifest b/net-analyzer/wapiti/Manifest
index b7bb6aeb259d..ecc0d6eab94b 100644
--- a/net-analyzer/wapiti/Manifest
+++ b/net-analyzer/wapiti/Manifest
@@ -1,3 +1 @@
-DIST wapiti3-3.0.5.tar.gz 573630 BLAKE2B 4f6425c54542e3fcf12f50a7ebe4aeeb38083bd04e6a9415466a24ca907e787149b6462972cb6c9d29f4c89bf1f941ae2566b126746bee3697172f342befd7fb SHA512 c1bfdcd4114ec508b4b16e7a4389b23b25326816c7daf0e7fb634ce08b59b983dec92f92287a18cbe7ecde9a06a04da98cfd744f818efc57c606be143fe7db4d
-DIST wapiti3-3.1.2.tar.gz 654586 BLAKE2B 6abbb35060ef554e8b803a82744527a361fe3803871b39dc078938c4af70a3f6e1a2adeec95c0ff487aff650d92a3638cb655439d342c2b516a5279ee02af472 SHA512 cd16d5b265a49441ad45341630ea6a2df150172b774d3282ee229b5a73274eed293ad35c6fc5e26443dc96f1437dcd28b77240210840c65cb3f1f7b6e9234c2d
DIST wapiti3-3.1.3.tar.gz 651457 BLAKE2B 7b0a0837012a25c4a0d4288730bb16dd056910d79e8d26712d7e508a9a51d7e23eb5fc29f0a619b534e2fe5e87262d91d4c29db50a02b500eb516c68f0850fc3 SHA512 321e068ddb117faa42c3f8cb01957ec7313a700bcb5b312b832d717a3957d3f6226bcf67c4348cc0b91cb13ec713828d0b03b662ea2f170d32f88d0721dd93bf
diff --git a/net-analyzer/wapiti/wapiti-3.0.5.ebuild b/net-analyzer/wapiti/wapiti-3.0.5.ebuild
deleted file mode 100644
index f181098a26f1..000000000000
--- a/net-analyzer/wapiti/wapiti-3.0.5.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_9 )
-PYTHON_REQ_USE='xml(+)'
-
-inherit distutils-r1
-
-MY_P=${PN}3-${PV}
-DESCRIPTION="Web-application vulnerability scanner"
-HOMEPAGE="http://wapiti.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="kerberos ntlm"
-
-RDEPEND="dev-python/beautifulsoup4[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/mako[${PYTHON_USEDEP}]
- >=dev-python/requests-1.2.3[${PYTHON_USEDEP}]
- dev-python/tld[${PYTHON_USEDEP}]
- dev-python/yaswfp[${PYTHON_USEDEP}]
- kerberos? ( dev-python/requests-kerberos[${PYTHON_USEDEP}] )
- ntlm? ( dev-python/requests-ntlm[${PYTHON_USEDEP}] )"
-
-distutils_enable_tests --install pytest
-BDEPEND+=" test? ( dev-python/responses[${PYTHON_USEDEP}] )"
-# Many tests require execution of local test php server
-RESTRICT="test"
-
-S=${WORKDIR}/${MY_P}
-
-python_prepare_all() {
- sed -e 's/"pytest-runner"//' \
- -e "/find_packages/s/()/(exclude=['tests*'])/" \
- -e "/DOC_DIR =/s/wapiti/${PF}/" \
- -i setup.py || die
- distutils-r1_python_prepare_all
-}
diff --git a/net-analyzer/wapiti/wapiti-3.1.2.ebuild b/net-analyzer/wapiti/wapiti-3.1.2.ebuild
deleted file mode 100644
index 0c3c245a76d7..000000000000
--- a/net-analyzer/wapiti/wapiti-3.1.2.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..10} )
-PYTHON_REQ_USE='xml(+)'
-
-inherit distutils-r1
-
-MY_P=${PN}3-${PV}
-DESCRIPTION="Web-application vulnerability scanner"
-HOMEPAGE="http://wapiti.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-# Requires httpx-ntlm (to package)
-#IUSE="ntlm"
-
-# httpx requires brotli and socks, so depending on
-# dev-python/socksio and dev-python/brotlicffi
-RDEPEND="dev-python/beautifulsoup4[${PYTHON_USEDEP}]
- dev-python/brotlicffi[${PYTHON_USEDEP}]
- dev-python/httpx[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/mako[${PYTHON_USEDEP}]
- >=dev-python/requests-1.2.3[${PYTHON_USEDEP}]
- dev-python/socksio[${PYTHON_USEDEP}]
- dev-python/tld[${PYTHON_USEDEP}]
- dev-python/yaswfp[${PYTHON_USEDEP}]"
-
-distutils_enable_tests --install pytest
-# Tests also require unpackaged respx
-BDEPEND+=" test? (
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- dev-python/responses[${PYTHON_USEDEP}]
- )"
-# Many tests require execution of local test php server
-RESTRICT="test"
-
-S=${WORKDIR}/${MY_P}
-
-python_prepare_all() {
- sed -e 's/"pytest-runner"//' \
- -e "/DOC_DIR =/s/wapiti/${PF}/" \
- -i setup.py || die
- distutils-r1_python_prepare_all
-}