summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/wapiti')
-rw-r--r--net-analyzer/wapiti/Manifest1
-rw-r--r--net-analyzer/wapiti/wapiti-3.1.7.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/net-analyzer/wapiti/Manifest b/net-analyzer/wapiti/Manifest
index cbb696ce4d8b..4ca8b3c31830 100644
--- a/net-analyzer/wapiti/Manifest
+++ b/net-analyzer/wapiti/Manifest
@@ -1 +1,2 @@
DIST wapiti3-3.1.6.tar.gz 538064 BLAKE2B fca98e05af7e4979ce5cc1360c565748b720f84e640accc9abd6d60017696827fb119228fec37bcf905e6e9f29c07ad5b9041a16fb49a6204777df07dd642bbd SHA512 8017d88c35a232f20f97297f5955154bead777a1b3d3937d29e6a39d2eeb5167764aa81286bfca5b9d200a29c25a6173052ddd8cbfebc1cb18aa84c0e2bb0e22
+DIST wapiti3-3.1.7.tar.gz 537866 BLAKE2B 2c58e20b5f754d5c461103a457aa18cfeb93b4ee7ca4c7525e29642f9cd027ece6f64a547b43b4c257c9cf27ae562ef9cb130e5635f1c13c9fdcda6b3f0a4ebf SHA512 d5a49a0f4c361f699f792b2b0c19a3ca65131534e5b244a8692137d1c63f120d33c47de41a6e4639316b63dd301396ae4f0b26f41259077ca34fba5065a36857
diff --git a/net-analyzer/wapiti/wapiti-3.1.7.ebuild b/net-analyzer/wapiti/wapiti-3.1.7.ebuild
new file mode 100644
index 000000000000..a797b298522c
--- /dev/null
+++ b/net-analyzer/wapiti/wapiti-3.1.7.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+# Deps missing for 3.12
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE='xml(+)'
+
+inherit distutils-r1
+
+MY_P=${PN}3-${PV}
+DESCRIPTION="Web-application vulnerability scanner"
+HOMEPAGE="https://wapiti.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+# Requires httpx-ntlm (to package)
+#IUSE="ntlm"
+IUSE="test"
+
+# httpx requires brotli and socks, so depending on
+# dev-python/socksio and dev-python/brotlicffi
+RDEPEND="
+ >=dev-python/aiocache-0.12.0[${PYTHON_USEDEP}]
+ >=dev-python/aiohttp-3.8.4[${PYTHON_USEDEP}]
+ >=dev-python/aiosqlite-0.17.0[${PYTHON_USEDEP}]
+ >=dev-python/arsenic-21.8[${PYTHON_USEDEP}]
+ >=dev-python/beautifulsoup4-4.10.0[${PYTHON_USEDEP}]
+ dev-python/brotlicffi[${PYTHON_USEDEP}]
+ >=dev-python/browser-cookie3-0.16.2[${PYTHON_USEDEP}]
+ >=dev-python/dnspython-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/h11-0.14[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.23.3[${PYTHON_USEDEP}]
+ >=dev-python/loguru-0.5.3[${PYTHON_USEDEP}]
+ >=dev-python/mako-1.1.4[${PYTHON_USEDEP}]
+ >=dev-python/markupsafe-2.1.1[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.4.8[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.2.3[${PYTHON_USEDEP}]
+ dev-python/socksio[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-1.4.26[${PYTHON_USEDEP}]
+ >=dev-python/tld-0.12.5[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.4.0[${PYTHON_USEDEP}]
+ >=dev-python/yaswfp-0.9.3[${PYTHON_USEDEP}]
+ >=net-proxy/mitmproxy-9.0.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+# Tests also require unpackaged respx
+BDEPEND+=" test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )"
+# Many tests require execution of local test php server
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.1.6-setup_scripts.patch )
+
+python_prepare_all() {
+ sed -e 's/"pytest-runner"//' \
+ -e "/DOC_DIR =/s/wapiti/${PF}/" \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}