summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/zmap/zmap-9999.ebuild')
-rw-r--r--net-analyzer/zmap/zmap-9999.ebuild42
1 files changed, 22 insertions, 20 deletions
diff --git a/net-analyzer/zmap/zmap-9999.ebuild b/net-analyzer/zmap/zmap-9999.ebuild
index eaed24c6933d..5d5794b8f52a 100644
--- a/net-analyzer/zmap/zmap-9999.ebuild
+++ b/net-analyzer/zmap/zmap-9999.ebuild
@@ -1,41 +1,43 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-inherit cmake-utils fcaps git-r3
+inherit cmake fcaps git-r3
DESCRIPTION="Fast network scanner designed for Internet-wide network surveys"
HOMEPAGE="https://zmap.io/"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+EGIT_REPO_URI="https://github.com/zmap/zmap.git"
-SLOT="0"
LICENSE="Apache-2.0"
-KEYWORDS=""
-IUSE="mongo redis"
+SLOT="0"
+IUSE="redis"
RDEPEND="
- dev-libs/gmp:0
+ dev-libs/gmp:=
net-libs/libpcap
dev-libs/json-c:=
- mongo? ( dev-db/mongodb )
- redis? ( dev-libs/hiredis )"
-DEPEND="${RDEPEND}
+ redis? ( dev-libs/hiredis:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
dev-util/gengetopt
- sys-devel/flex
+ app-alternatives/lex
dev-util/byacc
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.1.1-always-install-config.patch
+)
+
+FILECAPS=( cap_net_raw=ep usr/sbin/zmap )
+
src_configure() {
local mycmakeargs=(
-DENABLE_DEVELOPMENT=OFF
- -DENABLE_HARDENING=OFF
-DWITH_WERROR=OFF
- -DWITH_mongo="$(usex mongo)"
- -DWITH_redis="$(usex redis)"
- )
- cmake-utils_src_configure
-}
+ -DWITH_REDIS="$(usex redis)"
+ )
-FILECAPS=( cap_net_raw=ep usr/sbin/zmap )
+ cmake_src_configure
+}