summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/iptraf-ng/Manifest1
-rw-r--r--net-analyzer/iptraf-ng/iptraf-ng-1.2.0.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/net-analyzer/iptraf-ng/Manifest b/net-analyzer/iptraf-ng/Manifest
index 87ca62b426e7..7dfddeb87302 100644
--- a/net-analyzer/iptraf-ng/Manifest
+++ b/net-analyzer/iptraf-ng/Manifest
@@ -1,2 +1,3 @@
DIST iptraf-ng-1.1.4-github.tar.gz 556843 BLAKE2B 6f4e2bd8c4cf271d90732810f0ba6ab146b3471b723e657c180cf95ce8e1361d18c6803d5da56e872b0e49234956304fe1ff5532fde1332bc30a51a77ef8bdc0 SHA512 675165e08f979daf70fdbd0bd7ae24803860a182f3f1f6e6905f79f65b283470eedcc7e2f8608006c92af258cfad49c0b571652d843107cc79ad8eda63d4e5cb
DIST iptraf-ng-1.1.4.tar.gz 583306 BLAKE2B c06fdc25838901fc5528057ade5ebe28b5679a6a545f461cef2a5f4d3cbc1346a7ab3e94f4fe317a1760067e480c3c622df1027591d978b0ac1236ba9203e9da SHA512 8cafb0000cec75eb4071156a9e9350ffe6de99cb6386e8f50d05337113872ee50082a30009d85faa02d83633a8e727039791332d600654321b95ca6cfc881774
+DIST iptraf-ng-1.2.0.tar.gz 324841 BLAKE2B dab84b6c4d4266e51405fc8315361fa617bf41c7071d84a71021c73217e0cfaa7c9b327893e779f1970d99b9eab39baa0109359f973b80dd384cbe5744a5a78e SHA512 a9d24e5e32fb3525c32b952a24b8d74e65b0462cc4f98086d054cc259d4fff15e99d4f17bca6cc91ed3cc4f8e8d3cd3bd749423ce9c04933c50a808a9624a831
diff --git a/net-analyzer/iptraf-ng/iptraf-ng-1.2.0.ebuild b/net-analyzer/iptraf-ng/iptraf-ng-1.2.0.ebuild
new file mode 100644
index 000000000000..ccae3b8d8878
--- /dev/null
+++ b/net-analyzer/iptraf-ng/iptraf-ng-1.2.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="A console-based network monitoring utility"
+HOMEPAGE="https://github.com/iptraf-ng/iptraf-ng"
+SRC_URI="https://github.com/iptraf-ng/iptraf-ng/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 doc? ( FDL-1.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.7-r7:0=
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/os-headers
+ !net-analyzer/iptraf
+"
+RESTRICT="test"
+
+src_prepare() {
+ sed -i \
+ -e '/^CC =/d' \
+ -e '/^CFLAGS/s:= -g -O2:+= :' \
+ -e '/^LDFLAGS =/d' \
+ -e 's|$(QUIET_[[:alpha:]]*)||g' \
+ Makefile || die
+ sed -i \
+ -e 's|IPTRAF|&-NG|g' \
+ -e 's|IPTraf|&-NG|g' \
+ -e 's|iptraf|&-ng|g' \
+ src/*.8 || die
+
+ default
+}
+
+src_configure() {
+ # The configure script does not do very much we do not already control
+ append-cppflags '-DLOCKDIR=\"/run/lock/iptraf-ng\"'
+ tc-export CC
+}
+
+src_install() {
+ dosbin ${PN}
+
+ doman src/*.8
+ dodoc AUTHORS CHANGES* FAQ README*
+
+ if use doc; then
+ docinto html
+ dodoc -r Documentation/*
+ fi
+
+ keepdir /var/{lib,log}/iptraf-ng #376157
+}