summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/munin/munin-2.0.66-r3.ebuild (renamed from net-analyzer/munin/munin-2.0.66-r2.ebuild)9
-rw-r--r--net-analyzer/munin/munin-2.0.67-r6.ebuild (renamed from net-analyzer/munin/munin-2.0.67-r4.ebuild)9
-rw-r--r--net-analyzer/munin/munin-2.0.67-r7.ebuild (renamed from net-analyzer/munin/munin-2.0.67-r5.ebuild)9
3 files changed, 15 insertions, 12 deletions
diff --git a/net-analyzer/munin/munin-2.0.66-r2.ebuild b/net-analyzer/munin/munin-2.0.66-r3.ebuild
index 7a5621b5deb7..4d6837047b53 100644
--- a/net-analyzer/munin/munin-2.0.66-r2.ebuild
+++ b/net-analyzer/munin/munin-2.0.66-r3.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PATCHSET=1
-inherit java-pkg-opt-2 systemd
+inherit java-pkg-opt-2 systemd tmpfiles
MY_P=${P/_/-}
@@ -131,7 +131,7 @@ src_configure() {
local cgiuser=$(usex apache2 apache munin)
- cat >> "${S}"/Makefile.config <<- EOF
+ cat >> "${S}"/Makefile.config <<- EOF || die
PREFIX=\$(DESTDIR)/usr
CONFDIR=\$(DESTDIR)/etc/munin
DOCDIR=${T}/useless/doc
@@ -204,8 +204,7 @@ src_install() {
newinitd "${FILESDIR}"/munin-asyncd.init.2 munin-asyncd
- dodir /usr/lib/tmpfiles.d
- cat > "${D}"/usr/lib/tmpfiles.d/${CATEGORY}:${PN}:${SLOT}.conf <<- EOF
+ newtmpfiles - ${CATEGORY}:${PN}:${SLOT}.conf <<-EOF || die
d /run/munin 0700 munin munin - -
EOF
@@ -374,6 +373,8 @@ pkg_config() {
}
pkg_postinst() {
+ tmpfiles_process ${CATEGORY}:${PN}:${SLOT}.conf
+
elog "Please follow the munin documentation to set up the plugins you"
elog "need, afterwards start munin-node."
elog ""
diff --git a/net-analyzer/munin/munin-2.0.67-r4.ebuild b/net-analyzer/munin/munin-2.0.67-r6.ebuild
index 9f666d4ad680..b4ad2481fd45 100644
--- a/net-analyzer/munin/munin-2.0.67-r4.ebuild
+++ b/net-analyzer/munin/munin-2.0.67-r6.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PATCHSET=1
-inherit java-pkg-opt-2 systemd
+inherit java-pkg-opt-2 systemd tmpfiles
MY_P=${P/_/-}
@@ -131,7 +131,7 @@ src_configure() {
local cgiuser=$(usex apache2 apache munin)
- cat >> "${S}"/Makefile.config <<- EOF
+ cat >> "${S}"/Makefile.config <<- EOF || die
PREFIX=\$(DESTDIR)/usr
CONFDIR=\$(DESTDIR)/etc/munin
DOCDIR=${T}/useless/doc
@@ -204,8 +204,7 @@ src_install() {
newinitd "${FILESDIR}"/munin-asyncd.init.2 munin-asyncd
- dodir /usr/lib/tmpfiles.d
- cat > "${D}"/usr/lib/tmpfiles.d/${CATEGORY}:${PN}:${SLOT}.conf <<- EOF
+ newtmpfiles - ${CATEGORY}:${PN}:${SLOT}.conf <<-EOF || die
d /run/munin 0700 munin munin - -
EOF
@@ -374,6 +373,8 @@ pkg_config() {
}
pkg_postinst() {
+ tmpfiles_process ${CATEGORY}:${PN}:${SLOT}.conf
+
elog "Please follow the munin documentation to set up the plugins you"
elog "need, afterwards start munin-node."
elog ""
diff --git a/net-analyzer/munin/munin-2.0.67-r5.ebuild b/net-analyzer/munin/munin-2.0.67-r7.ebuild
index a0ed5615dc54..00a940ba1b5f 100644
--- a/net-analyzer/munin/munin-2.0.67-r5.ebuild
+++ b/net-analyzer/munin/munin-2.0.67-r7.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PATCHSET=1
-inherit java-pkg-opt-2 systemd
+inherit java-pkg-opt-2 systemd tmpfiles
MY_P=${P/_/-}
@@ -131,7 +131,7 @@ src_configure() {
local cgiuser=$(usex apache2 apache munin)
- cat >> "${S}"/Makefile.config <<- EOF
+ cat >> "${S}"/Makefile.config <<- EOF || die
PREFIX=\$(DESTDIR)/usr
CONFDIR=\$(DESTDIR)/etc/munin
DOCDIR=${T}/useless/doc
@@ -204,8 +204,7 @@ src_install() {
newinitd "${FILESDIR}"/munin-asyncd.init.2 munin-asyncd
- dodir /usr/lib/tmpfiles.d
- cat > "${D}"/usr/lib/tmpfiles.d/${CATEGORY}:${PN}:${SLOT}.conf <<- EOF
+ newtmpfiles - ${CATEGORY}:${PN}:${SLOT}.conf <<-EOF || die
d /run/munin 0700 munin munin - -
EOF
@@ -372,6 +371,8 @@ pkg_config() {
}
pkg_postinst() {
+ tmpfiles_process ${CATEGORY}:${PN}:${SLOT}.conf
+
elog "Please follow the munin documentation to set up the plugins you"
elog "need, afterwards start munin-node."
elog ""