summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/monitoring-plugins/Manifest2
-rw-r--r--net-analyzer/monitoring-plugins/monitoring-plugins-2.3.1-r5.ebuild109
-rw-r--r--net-analyzer/monitoring-plugins/monitoring-plugins-2.3.2-r2.ebuild105
3 files changed, 0 insertions, 216 deletions
diff --git a/net-analyzer/monitoring-plugins/Manifest b/net-analyzer/monitoring-plugins/Manifest
index 45a1c2ef1c62..545a0d98a9f7 100644
--- a/net-analyzer/monitoring-plugins/Manifest
+++ b/net-analyzer/monitoring-plugins/Manifest
@@ -1,4 +1,2 @@
-DIST monitoring-plugins-2.3.1.tar.gz 2529669 BLAKE2B 8dbbab78c1e57e249024fe57439acb41960585f2cccba20d03ca75a04b87e84752665f49cfe545c6a409d29094077dac0485aef872586f853e2f0f2187bf5070 SHA512 0ae76bc776997ed23d142ad9a688edc4df9b8ec0f9539b446e4fb4849a165cc88e97cbfb3a7a9a450de452e021d38f2e4ada7e8a22d78cf58e17e266472d01d7
-DIST monitoring-plugins-2.3.2.tar.gz 2766966 BLAKE2B 1a9c35e8df22d5666005b4b79f5a7ee878c0d4be1e98039f341b198a658747010e8c9d1c0a1818d67a402e5c302ec5eb5073628d52c29caf41dbc2ce57c18f6c SHA512 d155f09ddd99f4e0d065627d3bf8768e13ae3f58ed25912f33b070cd24d6f3f43243616ec3e2d496dec633feee6b1f14950035a928034a1413f725814e850765
DIST monitoring-plugins-2.3.3.tar.gz 2620192 BLAKE2B 47bd7e71cf470781bb3bd8c8437ebfccdc977e48a3eba1d83ba85c2c1a8c154c7db832e3bb7189bf669083a10069c7fe09c7235a00b35fd9a6d80afcdbb44246 SHA512 502274b47da2ad04d0e2e4e29baa7e5ad8b9a9ece36794dcdf7dfcc087de30e514ff6937eaaa26b93daad329fcd11b72c3c87cad826e6bf6bafffa450077706f
DIST monitoring-plugins-2.3.5.tar.gz 2876130 BLAKE2B 7029f6485ef73d29329bcb36e16cbbaa99c57ae20505f554af154b45cc1af6f623dabb35ee5b7f777d728bcae8eafd795f12aabc199cf1f45c9f2335f74b6d41 SHA512 bb04d547584a4aed82bfd605d129b652b45c7356c0610fb1da53a57b2ab889b67afccdd53998e2612ec06571bdc5fc238ef0d378b96e29ec072f657e74eabd55
diff --git a/net-analyzer/monitoring-plugins/monitoring-plugins-2.3.1-r5.ebuild b/net-analyzer/monitoring-plugins/monitoring-plugins-2.3.1-r5.ebuild
deleted file mode 100644
index b0bacbb75463..000000000000
--- a/net-analyzer/monitoring-plugins/monitoring-plugins-2.3.1-r5.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="8"
-
-inherit flag-o-matic
-
-DESCRIPTION="50+ standard plugins for Icinga, Naemon, Nagios, Shinken, Sensu"
-HOMEPAGE="https://www.monitoring-plugins.org/"
-SRC_URI="https://www.monitoring-plugins.org/download/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 sparc x86"
-IUSE="curl gnutls ipv6 ldap mysql dns fping game postgres radius samba snmp ssh +ssl"
-
-# Most of the plugins use automagic dependencies, i.e. the plugin will
-# get built if the binary it uses is installed. For example, check_snmp
-# will be built only if snmpget from net-analyzer/net-snmp[-minimal] is
-# installed. End result: most of our runtime dependencies are required
-# at build time as well.
-#
-# REAL_DEPEND contains the dependencies that are actually needed to
-# build. DEPEND contains those plus the automagic dependencies.
-#
-REAL_DEPEND="dev-lang/perl
- curl? (
- dev-libs/uriparser
- net-misc/curl
- )
- ldap? ( net-nds/openldap:= )
- mysql? ( || ( dev-db/mysql-connector-c dev-db/mariadb-connector-c ) )
- postgres? ( dev-db/postgresql:= )
- ssl? (
- !gnutls? (
- dev-libs/openssl:0=
- )
- gnutls? ( net-libs/gnutls )
- )
- radius? ( net-dialup/freeradius-client )"
-
-DEPEND="${REAL_DEPEND}
- dns? ( net-dns/bind-tools )
- game? ( games-util/qstat )
- fping? ( net-analyzer/fping )
- samba? ( net-fs/samba )
- ssh? ( virtual/openssh )
- snmp? ( dev-perl/Net-SNMP
- net-analyzer/net-snmp[-minimal] )"
-
-# Basically everything collides with nagios-plugins.
-RDEPEND="${DEPEND}
- acct-group/nagios
- acct-user/nagios
- !net-analyzer/nagios-plugins"
-
-# At least one test is interactive.
-RESTRICT="test"
-
-PATCHES=(
- "${FILESDIR}/${PN}-fix-check-disk-on-btrfs.patch" #830249
-)
-
-src_configure() {
- append-flags -fno-strict-aliasing
-
- # Use an array to prevent econf from mangling the ping args.
- local myconf=()
-
- if use ssl; then
- myconf+=( $(use_with !gnutls openssl /usr)
- $(use_with gnutls gnutls /usr) )
- else
- myconf+=( --without-openssl )
- myconf+=( --without-gnutls )
- fi
-
- # The autodetection for these two commands can hang if localhost is
- # down or ICMP traffic is filtered (bug #468296). But also the path
- # likes to move around on us (bug #883729).
- myconf+=( --with-ping-command="$(command -v ping) -4 -n -U -w %d -c %d %s" )
-
- if use ipv6; then
- myconf+=( --with-ping6-command="$(command -v ping) -6 -n -U -w %d -c %d %s" )
- fi
-
- econf \
- $(use_with curl libcurl) \
- $(use_with curl uriparser) \
- $(use_with mysql) \
- $(use_with ipv6) \
- $(use_with ldap) \
- $(use_with postgres pgsql /usr) \
- $(use_with radius) \
- "${myconf[@]}" \
- --libexecdir="/usr/$(get_libdir)/nagios/plugins" \
- --sysconfdir="/etc/nagios"
-}
-
-DOCS=( ACKNOWLEDGEMENTS AUTHORS CODING ChangeLog FAQ \
- NEWS README REQUIREMENTS SUPPORT THANKS )
-
-pkg_postinst() {
- elog "This ebuild has a number of USE flags that determine what you"
- elog "are able to monitor. Depending on what you want to monitor, some"
- elog "or all of these USE flags need to be set."
- elog
- elog "The plugins are installed in ${EROOT}/usr/$(get_libdir)/nagios/plugins"
-}
diff --git a/net-analyzer/monitoring-plugins/monitoring-plugins-2.3.2-r2.ebuild b/net-analyzer/monitoring-plugins/monitoring-plugins-2.3.2-r2.ebuild
deleted file mode 100644
index 3cea165dde1d..000000000000
--- a/net-analyzer/monitoring-plugins/monitoring-plugins-2.3.2-r2.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="8"
-
-inherit flag-o-matic
-
-DESCRIPTION="50+ standard plugins for Icinga, Naemon, Nagios, Shinken, Sensu"
-HOMEPAGE="https://www.monitoring-plugins.org/"
-SRC_URI="https://www.monitoring-plugins.org/download/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 sparc x86"
-IUSE="curl gnutls ipv6 ldap mysql dns fping game postgres radius samba snmp ssh +ssl"
-
-# Most of the plugins use automagic dependencies, i.e. the plugin will
-# get built if the binary it uses is installed. For example, check_snmp
-# will be built only if snmpget from net-analyzer/net-snmp[-minimal] is
-# installed. End result: most of our runtime dependencies are required
-# at build time as well.
-#
-# REAL_DEPEND contains the dependencies that are actually needed to
-# build. DEPEND contains those plus the automagic dependencies.
-#
-REAL_DEPEND="dev-lang/perl
- curl? (
- dev-libs/uriparser
- net-misc/curl
- )
- ldap? ( net-nds/openldap:= )
- mysql? ( || ( dev-db/mysql-connector-c dev-db/mariadb-connector-c ) )
- postgres? ( dev-db/postgresql:= )
- ssl? (
- !gnutls? (
- dev-libs/openssl:0=
- )
- gnutls? ( net-libs/gnutls )
- )
- radius? ( net-dialup/freeradius-client )"
-
-DEPEND="${REAL_DEPEND}
- dns? ( net-dns/bind-tools )
- game? ( games-util/qstat )
- fping? ( net-analyzer/fping )
- samba? ( net-fs/samba )
- ssh? ( virtual/openssh )
- snmp? ( dev-perl/Net-SNMP
- net-analyzer/net-snmp[-minimal] )"
-
-# Basically everything collides with nagios-plugins.
-RDEPEND="${DEPEND}
- acct-group/nagios
- acct-user/nagios
- !net-analyzer/nagios-plugins"
-
-# At least one test is interactive.
-RESTRICT="test"
-
-src_configure() {
- append-flags -fno-strict-aliasing
-
- # Use an array to prevent econf from mangling the ping args.
- local myconf=()
-
- if use ssl; then
- myconf+=( $(use_with !gnutls openssl /usr)
- $(use_with gnutls gnutls /usr) )
- else
- myconf+=( --without-openssl )
- myconf+=( --without-gnutls )
- fi
-
- # The autodetection for these two commands can hang if localhost is
- # down or ICMP traffic is filtered (bug #468296). But also the path
- # likes to move around on us (bug #883729).
- myconf+=( --with-ping-command="$(command -v ping) -4 -n -U -w %d -c %d %s" )
-
- if use ipv6; then
- myconf+=( --with-ping6-command="$(command -v ping) -6 -n -U -w %d -c %d %s" )
- fi
-
- econf \
- $(use_with curl libcurl) \
- $(use_with curl uriparser) \
- $(use_with mysql) \
- $(use_with ipv6) \
- $(use_with ldap) \
- $(use_with postgres pgsql /usr) \
- $(use_with radius) \
- "${myconf[@]}" \
- --libexecdir="/usr/$(get_libdir)/nagios/plugins" \
- --sysconfdir="/etc/nagios"
-}
-
-DOCS=( ACKNOWLEDGEMENTS AUTHORS CODING ChangeLog FAQ \
- NEWS README REQUIREMENTS SUPPORT THANKS )
-
-pkg_postinst() {
- elog "This ebuild has a number of USE flags that determine what you"
- elog "are able to monitor. Depending on what you want to monitor, some"
- elog "or all of these USE flags need to be set."
- elog
- elog "The plugins are installed in ${EROOT}/usr/$(get_libdir)/nagios/plugins"
-}