summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/wapiti/Manifest1
-rw-r--r--net-analyzer/wapiti/metadata.xml3
-rw-r--r--net-analyzer/wapiti/wapiti-3.1.6.ebuild53
3 files changed, 55 insertions, 2 deletions
diff --git a/net-analyzer/wapiti/Manifest b/net-analyzer/wapiti/Manifest
index ecc0d6eab94b..800bd013b261 100644
--- a/net-analyzer/wapiti/Manifest
+++ b/net-analyzer/wapiti/Manifest
@@ -1 +1,2 @@
DIST wapiti3-3.1.3.tar.gz 651457 BLAKE2B 7b0a0837012a25c4a0d4288730bb16dd056910d79e8d26712d7e508a9a51d7e23eb5fc29f0a619b534e2fe5e87262d91d4c29db50a02b500eb516c68f0850fc3 SHA512 321e068ddb117faa42c3f8cb01957ec7313a700bcb5b312b832d717a3957d3f6226bcf67c4348cc0b91cb13ec713828d0b03b662ea2f170d32f88d0721dd93bf
+DIST wapiti3-3.1.6.tar.gz 538064 BLAKE2B fca98e05af7e4979ce5cc1360c565748b720f84e640accc9abd6d60017696827fb119228fec37bcf905e6e9f29c07ad5b9041a16fb49a6204777df07dd642bbd SHA512 8017d88c35a232f20f97297f5955154bead777a1b3d3937d29e6a39d2eeb5167764aa81286bfca5b9d200a29c25a6173052ddd8cbfebc1cb18aa84c0e2bb0e22
diff --git a/net-analyzer/wapiti/metadata.xml b/net-analyzer/wapiti/metadata.xml
index cbfe6085afed..4de9c0e68a4e 100644
--- a/net-analyzer/wapiti/metadata.xml
+++ b/net-analyzer/wapiti/metadata.xml
@@ -14,7 +14,6 @@ Once it gets this list, Wapiti acts like a fuzzer, injecting payloads to see if
<remote-id type="sourceforge">wapiti</remote-id>
</upstream>
<use>
- <flag name="kerberos">Support Kerberos authentication</flag>
- <flag name="ntlm">Support NTLM authentication</flag>
+ <!-- Need extra dep <flag name="ntlm">Support NTLM authentication</flag> -->
</use>
</pkgmetadata>
diff --git a/net-analyzer/wapiti/wapiti-3.1.6.ebuild b/net-analyzer/wapiti/wapiti-3.1.6.ebuild
new file mode 100644
index 000000000000..3ab9a88d574c
--- /dev/null
+++ b/net-analyzer/wapiti/wapiti-3.1.6.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE='xml(+)'
+
+inherit distutils-r1
+
+MY_P=${PN}3-${PV}
+DESCRIPTION="Web-application vulnerability scanner"
+HOMEPAGE="http://wapiti.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# Requires httpx-ntlm (to package)
+#IUSE="ntlm"
+IUSE="test"
+
+# httpx requires brotli and socks, so depending on
+# dev-python/socksio and dev-python/brotlicffi
+RDEPEND="dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/brotlicffi[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.2.3[${PYTHON_USEDEP}]
+ dev-python/socksio[${PYTHON_USEDEP}]
+ dev-python/tld[${PYTHON_USEDEP}]
+ dev-python/yaswfp[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+# Tests also require unpackaged respx
+BDEPEND+=" test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )"
+# Many tests require execution of local test php server
+RESTRICT="test"
+
+S=${WORKDIR}/${MY_P}
+
+python_prepare_all() {
+ sed -e 's/"pytest-runner"//' \
+ -e "/DOC_DIR =/s/wapiti/${PF}/" \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}