summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dialup/freeradius-client/freeradius-client-1.1.7.ebuild')
-rw-r--r--net-dialup/freeradius-client/freeradius-client-1.1.7.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-dialup/freeradius-client/freeradius-client-1.1.7.ebuild b/net-dialup/freeradius-client/freeradius-client-1.1.7.ebuild
new file mode 100644
index 000000000000..8b0aa5696092
--- /dev/null
+++ b/net-dialup/freeradius-client/freeradius-client-1.1.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit autotools-utils
+
+DESCRIPTION="FreeRADIUS Client framework"
+HOMEPAGE="http://wiki.freeradius.org/Radiusclient"
+SRC_URI="ftp://ftp.freeradius.org/pub/freeradius/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="scp shadow static-libs"
+
+DEPEND="!net-dialup/radiusclient
+ !net-dialup/radiusclient-ng"
+RDEPEND="${DEPEND}"
+
+DOCS=( BUGS doc/ChangeLog doc/login.example doc/release-method.txt )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable scp)
+ $(use_enable shadow)
+ --with-secure-path
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ dodoc README*
+ newdoc doc/README README.login.example
+ dohtml doc/instop.html
+}