summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/picocom/Manifest1
-rw-r--r--net-dialup/picocom/picocom-2.2.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/net-dialup/picocom/Manifest b/net-dialup/picocom/Manifest
index ed918cfd0dde..dfd179c17492 100644
--- a/net-dialup/picocom/Manifest
+++ b/net-dialup/picocom/Manifest
@@ -1 +1,2 @@
DIST picocom-2.1.tar.gz 89281 SHA256 6b152fc5f816eaef6b86336a4cec7cf1496b7c712061e5aea5a36f143a0b09ed SHA512 0df692118e3cfa27edd8ff9d5abbde8a9dc02fb015476ab1469337d616eb69411db125a967107276fb50bc58e7b9748429b9ded4943712a082a10827d595c03e WHIRLPOOL 6c0a3e1080dd49ad2fd9863fd3c5cb21d9bbaca4b580145ffd20b76566109a4a18ee6b837bd192254848370206319e963cd07fe93955f85a2459297ad228c641
+DIST picocom-2.2.tar.gz 88670 SHA256 3e3904158d675541f0fcfdcd1f671b38445338f536080f5de8d6674b5f33d4ce SHA512 21495af30b81dfd1b3f4fea1ecf93c3a9252be1ae2ba94c7a2a07ceb75f562bc2ebc6ef6a8ae61f810ff5c121d4ab572a6f8ba75283e2cb28cf9886f834df0fa WHIRLPOOL 0c5aa85cbb8255e90632d737566bf4349169cdfbdc83cb65be617a87c8837a0d4fd3646061d816fc5ae6fbad761f97eb587b3572e163c0e0d0c183fddc900c8d
diff --git a/net-dialup/picocom/picocom-2.2.ebuild b/net-dialup/picocom/picocom-2.2.ebuild
new file mode 100644
index 000000000000..9fb2b2291201
--- /dev/null
+++ b/net-dialup/picocom/picocom-2.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="minimal dumb-terminal emulation program"
+HOMEPAGE="https://github.com/npat-efault/picocom"
+SRC_URI="https://github.com/npat-efault/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+src_compile() {
+ # CPPFLAGS is shared between CFLAGS and CXXFLAGS, but there is no
+ # C++ file, and the pre-processor is never called directly, this
+ # is easier than patching it out.
+ emake LDFLAGS="${LDFLAGS}" CFLAGS="${CFLAGS} ${CPPFLAGS} -Wall" \
+ CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin picocom pc{asc,xm,ym,zm}
+ doman picocom.1
+ dodoc CHANGES.old CONTRIBUTORS README.md
+}