summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns/coredns/files')
-rw-r--r--net-dns/coredns/files/buildopts-gitcommit-makefile-1.11.1.patch29
-rw-r--r--net-dns/coredns/files/coredns.service4
2 files changed, 32 insertions, 1 deletions
diff --git a/net-dns/coredns/files/buildopts-gitcommit-makefile-1.11.1.patch b/net-dns/coredns/files/buildopts-gitcommit-makefile-1.11.1.patch
new file mode 100644
index 000000000000..97dd658786e6
--- /dev/null
+++ b/net-dns/coredns/files/buildopts-gitcommit-makefile-1.11.1.patch
@@ -0,0 +1,29 @@
+# https://github.com/coredns/coredns/pull/6384
+From 81938bca2041c9dddc1171d56f609191313b8b9d Mon Sep 17 00:00:00 2001
+From: Rahil Bhimjiani <rahil3108@gmail.com>
+Date: Sun, 5 Nov 2023 21:53:05 +0530
+Subject: [PATCH] Makefile: allow to use custom GITCOMMIT & BUILDOPTS
+
+?= means If GITCOMMIT/BUILDOPTS is defined then use that otherwise fallback to default
+
+Signed-off-by: Rahil Bhimjiani <rahil3108@gmail.com>
+---
+ Makefile | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 43d03e207ba..10fca3da1a1 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,9 +1,9 @@
+ # Makefile for building CoreDNS
+-GITCOMMIT:=$(shell git describe --dirty --always)
++GITCOMMIT?=$(shell git describe --dirty --always)
+ BINARY:=coredns
+ SYSTEM:=
+ CHECKS:=check
+-BUILDOPTS:=-v
++BUILDOPTS?=-v
+ GOPATH?=$(HOME)/go
+ MAKEPWD:=$(dir $(realpath $(firstword $(MAKEFILE_LIST))))
+ CGO_ENABLED?=0
diff --git a/net-dns/coredns/files/coredns.service b/net-dns/coredns/files/coredns.service
index eab9aede713e..fc2ec10c5c43 100644
--- a/net-dns/coredns/files/coredns.service
+++ b/net-dns/coredns/files/coredns.service
@@ -1,7 +1,9 @@
[Unit]
Description=CoreDNS DNS server
+Documentation=man:coredns(1)
Documentation=https://coredns.io
-After=network.target
+After=network-online.target
+Wants=network-online.target
[Service]
PermissionsStartOnly=true