summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns/dnscrypt-proxy')
-rw-r--r--net-dns/dnscrypt-proxy/Manifest2
-rw-r--r--net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.0.ebuild88
-rw-r--r--net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.4.ebuild88
-rw-r--r--net-dns/dnscrypt-proxy/files/config-full-paths-r2.patch95
4 files changed, 0 insertions, 273 deletions
diff --git a/net-dns/dnscrypt-proxy/Manifest b/net-dns/dnscrypt-proxy/Manifest
index fbfcefae2f24..0bf5057ad6ed 100644
--- a/net-dns/dnscrypt-proxy/Manifest
+++ b/net-dns/dnscrypt-proxy/Manifest
@@ -1,4 +1,2 @@
DIST dnscrypt-proxy-1.9.5.tar.bz2 1290573 BLAKE2B 8f16fdb58012e00a8b58d36364377c3bc25158b9484a8df2bd6bc98d1c9cbf5ac758997e31f95ecaeb9da2f6b7272316c5a4a1c069a39549fbc1c1b136857da0 SHA512 84c0f7587521b3a198292cf20dd71cb592ccf8a9e003abbc62c5ca112f6c5ed27c49b1642cf91f403d52b4147e25f24af540b65cecfcf93814338329097df836
-DIST dnscrypt-proxy-2.0.0.tar.gz 725490 BLAKE2B d4c116f81d304b9b3a883ba6b414e2fef810f50ecea9a9175246d02f2755c3e11c9940fed0dfc221e419820e001abc74e4bf4478abb2222b548461ad09f3f57d SHA512 c87420c09fc45496901b0c21ae972283f05c508b07249450de504ba5e287128c2c5e0f772b181ddb2f6478cb6d66e72617e3b0679f47f3b15dde80c92d2ef7ba
-DIST dnscrypt-proxy-2.0.4.tar.gz 727969 BLAKE2B 80f29fbc150f8731dce0ab0af8f4282264b19fade73846f972bd0e762bfe4ebd1a0f014fb6fad860623377c833c099f1d50d8ab7ccd8cecb7e210a422d96ea99 SHA512 ba8f419c85b3ccd0bdd930404c3781f1cadf58dcacb30bf35c3be0933887a6dc910496424cb3847ef2630b8205794cef03d980ac82605faca38c6bfd58b213be
DIST dnscrypt-proxy-2.0.6.tar.gz 744263 BLAKE2B c24acf7fbdf007b58e674f4c01db5bc3ea84d974c902086840f64c890bd72a64828283400e5f1f9c5d5f1c6a0e8233a366c33db3e3cdbec2e942a6d973091fb8 SHA512 f581b3663d5162ebd3fa5971c1af96e192b644e806578899ec37b86dceb3823fbfe1102cc8748cba361f3d000c4e952133e2dc92b94c6276819e37e07af6f0e5
diff --git a/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.0.ebuild b/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.0.ebuild
deleted file mode 100644
index 5e497f135323..000000000000
--- a/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.0.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-EGO_PN="github.com/jedisct1/${PN}"
-
-inherit fcaps golang-build systemd user
-
-DESCRIPTION="A flexible DNS proxy, with support for encrypted DNS protocols"
-HOMEPAGE="https://github.com/jedisct1/dnscrypt-proxy"
-SRC_URI="https://${EGO_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-FILECAPS=( cap_net_bind_service+ep usr/bin/dnscrypt-proxy )
-PATCHES=( "${FILESDIR}"/config-full-paths-r2.patch )
-
-pkg_setup() {
- enewgroup dnscrypt
- enewuser dnscrypt -1 -1 /var/empty dnscrypt
-}
-
-src_compile() {
- # Create directory structure suitable for building
- mkdir -p "src/${EGO_PN%/*}" || die
- mv "${PN}" "src/${EGO_PN}" || die
- mv "vendor" "src/" || die
- golang-build_src_compile
-}
-
-src_install() {
- dobin dnscrypt-proxy
-
- insinto /etc/dnscrypt-proxy
- newins "src/${EGO_PN}"/example-dnscrypt-proxy.toml dnscrypt-proxy.toml
- doins "src/${EGO_PN}"/example-{blacklist.txt,cloaking-rules.txt,forwarding-rules.txt}
-
- insinto "/usr/share/dnscrypt-proxy"
- doins -r "utils/generate-domains-blacklists/."
-
- newinitd "${FILESDIR}"/dnscrypt-proxy.initd-r2 dnscrypt-proxy
- newconfd "${FILESDIR}"/dnscrypt-proxy.confd-r2 dnscrypt-proxy
- systemd_newunit "${FILESDIR}"/${PN}.service-r2 dnscrypt-proxy.service
- systemd_dounit systemd/dnscrypt-proxy.socket
-
- keepdir /var/log/dnscrypt-proxy
-
- einstalldocs
-}
-
-pkg_postinst() {
- fcaps_pkg_postinst
-
- if ! use filecaps; then
- ewarn "'filecaps' USE flag is disabled"
- ewarn "${PN} will fail to listen on port 53 if started via OpenRC"
- ewarn "please either change port to > 1024, configure to run ${PN} as root"
- ewarn "or re-enable 'filecaps'"
- ewarn
- fi
-
- local v
- for v in ${REPLACING_VERSIONS}; do
- if [[ ${v} == 1.* ]] ; then
- elog "Version 2.x.x is a complete rewrite of ${PN}"
- elog "please clean up old config/log files"
- elog
- fi
- done
-
- if systemd_is_booted || has_version sys-apps/systemd; then
- elog "To use systemd socket activation with ${PN} you must"
- elog "set listen_addresses setting to \"[]\" in the config file"
- elog "Edit ${PN}.socket if you need to change port and address"
- elog
- fi
-
- elog "After starting the service you will need to update your"
- elog "/etc/resolv.conf and replace your current set of resolvers"
- elog "with:"
- elog
- elog "nameserver 127.0.0.1"
- elog
- elog "Also see https://github.com/jedisct1/${PN}/wiki"
-}
diff --git a/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.4.ebuild b/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.4.ebuild
deleted file mode 100644
index 5e497f135323..000000000000
--- a/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.4.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-EGO_PN="github.com/jedisct1/${PN}"
-
-inherit fcaps golang-build systemd user
-
-DESCRIPTION="A flexible DNS proxy, with support for encrypted DNS protocols"
-HOMEPAGE="https://github.com/jedisct1/dnscrypt-proxy"
-SRC_URI="https://${EGO_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-FILECAPS=( cap_net_bind_service+ep usr/bin/dnscrypt-proxy )
-PATCHES=( "${FILESDIR}"/config-full-paths-r2.patch )
-
-pkg_setup() {
- enewgroup dnscrypt
- enewuser dnscrypt -1 -1 /var/empty dnscrypt
-}
-
-src_compile() {
- # Create directory structure suitable for building
- mkdir -p "src/${EGO_PN%/*}" || die
- mv "${PN}" "src/${EGO_PN}" || die
- mv "vendor" "src/" || die
- golang-build_src_compile
-}
-
-src_install() {
- dobin dnscrypt-proxy
-
- insinto /etc/dnscrypt-proxy
- newins "src/${EGO_PN}"/example-dnscrypt-proxy.toml dnscrypt-proxy.toml
- doins "src/${EGO_PN}"/example-{blacklist.txt,cloaking-rules.txt,forwarding-rules.txt}
-
- insinto "/usr/share/dnscrypt-proxy"
- doins -r "utils/generate-domains-blacklists/."
-
- newinitd "${FILESDIR}"/dnscrypt-proxy.initd-r2 dnscrypt-proxy
- newconfd "${FILESDIR}"/dnscrypt-proxy.confd-r2 dnscrypt-proxy
- systemd_newunit "${FILESDIR}"/${PN}.service-r2 dnscrypt-proxy.service
- systemd_dounit systemd/dnscrypt-proxy.socket
-
- keepdir /var/log/dnscrypt-proxy
-
- einstalldocs
-}
-
-pkg_postinst() {
- fcaps_pkg_postinst
-
- if ! use filecaps; then
- ewarn "'filecaps' USE flag is disabled"
- ewarn "${PN} will fail to listen on port 53 if started via OpenRC"
- ewarn "please either change port to > 1024, configure to run ${PN} as root"
- ewarn "or re-enable 'filecaps'"
- ewarn
- fi
-
- local v
- for v in ${REPLACING_VERSIONS}; do
- if [[ ${v} == 1.* ]] ; then
- elog "Version 2.x.x is a complete rewrite of ${PN}"
- elog "please clean up old config/log files"
- elog
- fi
- done
-
- if systemd_is_booted || has_version sys-apps/systemd; then
- elog "To use systemd socket activation with ${PN} you must"
- elog "set listen_addresses setting to \"[]\" in the config file"
- elog "Edit ${PN}.socket if you need to change port and address"
- elog
- fi
-
- elog "After starting the service you will need to update your"
- elog "/etc/resolv.conf and replace your current set of resolvers"
- elog "with:"
- elog
- elog "nameserver 127.0.0.1"
- elog
- elog "Also see https://github.com/jedisct1/${PN}/wiki"
-}
diff --git a/net-dns/dnscrypt-proxy/files/config-full-paths-r2.patch b/net-dns/dnscrypt-proxy/files/config-full-paths-r2.patch
deleted file mode 100644
index b693f1abbb32..000000000000
--- a/net-dns/dnscrypt-proxy/files/config-full-paths-r2.patch
+++ /dev/null
@@ -1,95 +0,0 @@
---- dnscrypt-proxy-2.0.0/dnscrypt-proxy/example-dnscrypt-proxy.toml 2018-02-06 10:33:58.000000000 -0800
-+++ dnscrypt-proxy-2.0.0/dnscrypt-proxy/dnscrypt-proxy.toml 2018-02-09 19:15:00.105927884 -0800
-@@ -85,7 +85,7 @@
-
- ## log file for the application
-
--# log_file = 'dnscrypt-proxy.log'
-+# log_file = '/var/log/dnscrypt-proxy/dnscrypt-proxy.log'
-
-
- ## Use the system logger (syslog on Unix, Event Log on Windows)
-@@ -140,7 +140,7 @@
- ## example.com 9.9.9.9
- ## example.net 9.9.9.9,8.8.8.8
-
--# forwarding_rules = 'forwarding-rules.txt'
-+# forwarding_rules = '/etc/dnscrypt-proxy/forwarding-rules.txt'
-
-
-
-@@ -156,7 +156,7 @@
- ## example.com 10.1.1.1
- ## www.google.com forcesafesearch.google.com
-
--# cloaking_rules = 'cloaking-rules.txt'
-+# cloaking_rules = '/etc/dnscrypt-proxy/cloaking-rules.txt'
-
-
-
-@@ -200,7 +200,7 @@
-
- ## Path to the query log file (absolute, or relative to the same directory as the executable file)
-
-- # file = 'query.log'
-+ # file = '/var/log/dnscrypt-proxy/query.log'
-
-
- ## Query log format (currently supported: tsv and ltsv)
-@@ -226,7 +226,7 @@
-
- ## Path to the query log file (absolute, or relative to the same directory as the executable file)
-
-- # file = 'nx.log'
-+ # file = '/var/log/dnscrypt-proxy/nx.log'
-
-
- ## Query log format (currently supported: tsv and ltsv)
-@@ -255,12 +255,12 @@
-
- ## Path to the file of blocking rules (absolute, or relative to the same directory as the executable file)
-
-- # blacklist_file = 'blacklist.txt'
-+ # blacklist_file = '/etc/dnscrypt-proxy/blacklist.txt'
-
-
- ## Optional path to a file logging blocked queries
-
-- # log_file = 'blocked.log'
-+ # log_file = '/var/log/dnscrypt-proxy/blocked.log'
-
-
- ## Optional log format: tsv or ltsv (default: tsv)
-@@ -283,12 +283,12 @@
-
- ## Path to the file of blocking rules (absolute, or relative to the same directory as the executable file)
-
-- # blacklist_file = 'ip-blacklist.txt'
-+ # blacklist_file = '/etc/dnscrypt-proxy/ip-blacklist.txt'
-
-
- ## Optional path to a file logging blocked queries
-
-- # log_file = 'ip-blocked.log'
-+ # log_file = '/var/log/dnscrypt-proxy/ip-blocked.log'
-
-
- ## Optional log format: tsv or ltsv (default: tsv)
-@@ -357,7 +357,7 @@
-
- [sources.'public-resolvers']
- url = 'https://download.dnscrypt.info/resolvers-list/v2/public-resolvers.md'
-- cache_file = 'public-resolvers.md'
-+ cache_file = '/var/cache/dnscrypt-proxy/public-resolvers.md'
- minisign_key = 'RWQf6LRCGA9i53mlYecO4IzT51TGPpvWucNSCh1CBM0QTaLn73Y7GFO3'
- refresh_delay = 72
- prefix = ''
-@@ -367,7 +367,7 @@
-
- # [sources.'parental-control']
- # url = 'https://download.dnscrypt.info/resolvers-list/v2/parental-control.md'
-- # cache_file = 'parental-control.md'
-+ # cache_file = '/var/cache/dnscrypt-proxy/parental-control.md'
- # minisign_key = 'RWQf6LRCGA9i53mlYecO4IzT51TGPpvWucNSCh1CBM0QTaLn73Y7GFO3'
-
-