summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns/dnsmasq')
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.80-r1.ebuild5
-rw-r--r--net-dns/dnsmasq/files/dnsmasq-2.80-linux-headers-5.2.patch25
2 files changed, 29 insertions, 1 deletions
diff --git a/net-dns/dnsmasq/dnsmasq-2.80-r1.ebuild b/net-dns/dnsmasq/dnsmasq-2.80-r1.ebuild
index 20c55be8ff0c..e73c42b41c10 100644
--- a/net-dns/dnsmasq/dnsmasq-2.80-r1.ebuild
+++ b/net-dns/dnsmasq/dnsmasq-2.80-r1.ebuild
@@ -1,5 +1,4 @@
# Copyright 1999-2019 Gentoo Authors
-# Copyright 2017-2018 Sony Interactive Entertainment Inc.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -58,6 +57,10 @@ REQUIRED_USE="dhcp-tools? ( dhcp )
lua? ( script )
libidn2? ( idn )"
+PATCHES=(
+ "${FILESDIR}/dnsmasq-2.80-linux-headers-5.2.patch"
+)
+
use_have() {
local useflag no_only uword
if [[ ${1} == '-n' ]]; then
diff --git a/net-dns/dnsmasq/files/dnsmasq-2.80-linux-headers-5.2.patch b/net-dns/dnsmasq/files/dnsmasq-2.80-linux-headers-5.2.patch
new file mode 100644
index 000000000000..21bd7cd39ff6
--- /dev/null
+++ b/net-dns/dnsmasq/files/dnsmasq-2.80-linux-headers-5.2.patch
@@ -0,0 +1,25 @@
+From 3052ce208acf602f0163166dcefb7330d537cedb Mon Sep 17 00:00:00 2001
+From: Jiri Slaby <jslaby@suse.cz>
+Date: Wed, 24 Jul 2019 17:34:48 +0100
+Subject: [PATCH] Fix build after y2038 changes in glib.
+
+SIOCGSTAMP is defined in linux/sockios.h, not asm/sockios.h now.
+---
+ src/dnsmasq.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/dnsmasq.h b/src/dnsmasq.h
+index ff3204a..3ef04ad 100644
+--- a/src/dnsmasq.h
++++ b/src/dnsmasq.h
+@@ -137,6 +137,7 @@ typedef unsigned long long u64;
+ #endif
+
+ #if defined(HAVE_LINUX_NETWORK)
++#include <linux/sockios.h>
+ #include <linux/capability.h>
+ /* There doesn't seem to be a universally-available
+ userspace header for these. */
+--
+1.7.10.4
+