summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/pdns-recursor/Manifest2
-rw-r--r--net-dns/pdns-recursor/pdns-recursor-4.4.7.ebuild88
-rw-r--r--net-dns/pdns-recursor/pdns-recursor-4.5.7.ebuild82
3 files changed, 172 insertions, 0 deletions
diff --git a/net-dns/pdns-recursor/Manifest b/net-dns/pdns-recursor/Manifest
index af59130576ce..8a8ffce2e05a 100644
--- a/net-dns/pdns-recursor/Manifest
+++ b/net-dns/pdns-recursor/Manifest
@@ -1,4 +1,6 @@
DIST pdns-recursor-4.4.5.tar.bz2 1400394 BLAKE2B a373d15987860bd6b890e5aa5900f28623ff763a711e527b05c3de950c7fbec186dc5e085100008a8ee89bab24140b0f993357349ec04d968e7f386156cdefbc SHA512 21f4172bb8908cfb53e8d457533a85940b13da6733c2da3972b587e64a0f6d52bfd52b85d5d65769c33dd479ce89b6306bdd105c120ab99b32963e7f0cfbc2e2
DIST pdns-recursor-4.4.6.tar.bz2 1403882 BLAKE2B 2f860128849cce29131300cbda2f2646c7fbaeeb704a6131933d3bbe205bdf1dddd45f9f79f74345b2dea34e56d145b9ef878c0cd6280ceeb075c196afe53d5e SHA512 0ac897da628fb133bd7cd3932e0a1d362c88c55cb07dc2d5d645f731dc8dbf5d18993967654a60156cba7eaac7869ee10a67987a2a492c0c239de9788188caf4
+DIST pdns-recursor-4.4.7.tar.bz2 1404116 BLAKE2B 42808634fe20735ba0a933a20b7c4dfae0c32b25976e713be46dddfcdf03599b2b29ca8407781ac304fcb004f8a8a29856dc70aeb468f4e773ee5e5a9d1e7631 SHA512 eb4008ec65e42e10d9fc4d0e0fc6c4d4716224f04f530649d88adbc505ea2a8b570bfd738455f9c769e6c242e7996905c7cc457e9f685b06e5d0f73fdffd30a7
DIST pdns-recursor-4.5.5.tar.bz2 1472089 BLAKE2B 408bd0d11b0945de15fe22b290b127a9b7f9f053359a0269fb9e478ae536ed5c4b5ad3b5fa8b15d7786fdd0cdd8721d5a5cb66d46f816105e37ecd9fc9557854 SHA512 7df2e89eea55e870724370753b39d867e2b32fc8bcbdb3efaefa824917b16b9d382817dce7d551dc16d8ad0b0c04b3021cba310b47de969fe54c395eafe7706b
DIST pdns-recursor-4.5.6.tar.bz2 1474500 BLAKE2B 9d1f0ce83b4d57d6443cf0107d76c4408aee019b571d807167429b56ce543809732610b0ca1f2d406224de33d1bcb747e00b572178ef6748282dc6a62fcafe78 SHA512 43c866a29bd72175bad71450dc20678183f6b11f60d54a174627501be52c79dc91819196be63e6859af086f42cc7297d7a3a6100088a2efe3c99eb8f5fd73e71
+DIST pdns-recursor-4.5.7.tar.bz2 1475537 BLAKE2B e58a28ed1ca2a9ae69436f9367e83f046ed5bc47bfd13783bd7c956f917c4a6d9c93a9a8e1c4df55ad42bc6ba024faca936fefdaffb2125e4f6635c5e6a20b19 SHA512 dc4a2a129039f79440420c285c37fd11536f2c0b74a39da74560eb782f1ad881839831e97f2a803b1812f128e899ad7c460fada42a831994b21f301f8892e60a
diff --git a/net-dns/pdns-recursor/pdns-recursor-4.4.7.ebuild b/net-dns/pdns-recursor/pdns-recursor-4.4.7.ebuild
new file mode 100644
index 000000000000..dc546d8cd6ca
--- /dev/null
+++ b/net-dns/pdns-recursor/pdns-recursor-4.4.7.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit flag-o-matic lua-single
+
+DESCRIPTION="The PowerDNS Recursor"
+HOMEPAGE="https://www.powerdns.com/"
+SRC_URI="https://downloads.powerdns.com/releases/${P/_/-}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug dnstap protobuf snmp sodium systemd test"
+REQUIRED_USE="${LUA_REQUIRED_USE}
+ dnstap? ( protobuf )"
+RESTRICT="!test? ( test )"
+
+DEPEND="${LUA_DEPS}
+ protobuf? (
+ dev-libs/protobuf
+ >=dev-libs/boost-1.42:=
+ )
+ dnstap? ( dev-libs/fstrm )
+ systemd? ( sys-apps/systemd:0= )
+ snmp? ( net-analyzer/net-snmp )
+ sodium? ( dev-libs/libsodium:= )
+ dev-libs/openssl:=
+ >=dev-libs/boost-1.35:="
+RDEPEND="${DEPEND}
+ !<net-dns/pdns-2.9.20-r1
+ acct-user/pdns
+ acct-group/pdns"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}"/${P/_/-}
+
+pkg_setup() {
+ lua-single_pkg_setup
+ filter-flags -ftree-vectorize
+}
+
+src_configure() {
+ econf \
+ --sysconfdir=/etc/powerdns \
+ --with-nod-cache-dir=/var/lib/powerdns \
+ --with-service-user=pdns \
+ --with-service-group=pdns \
+ --with-lua="${ELUA}" \
+ $(use_enable debug verbose-logging) \
+ $(use_enable systemd) \
+ $(use_enable dnstap dnstap) \
+ $(use_enable test unit-tests) \
+ $(use_with sodium libsodium) \
+ $(use_with protobuf) \
+ $(use_with snmp net-snmp)
+}
+
+src_install() {
+ default
+
+ mv "${D}"/etc/powerdns/recursor.conf{-dist,}
+
+ # set defaults: setuid=nobody, setgid=nobody
+ sed -i \
+ -e 's/^# set\([ug]\)id=$/set\1id=pdns/' \
+ -e 's/^# quiet=$/quiet=on/' \
+ -e 's/^# chroot=$/chroot=\/var\/lib\/powerdns/' \
+ "${D}"/etc/powerdns/recursor.conf
+
+ newinitd "${FILESDIR}"/pdns-recursor-r2 pdns-recursor
+}
+
+pkg_postinst() {
+ local old
+
+ for old in ${REPLACING_VERSIONS}; do
+ ver_test ${old} -lt 4.0.0-r1 || continue
+
+ ewarn "Starting with 4.0.0-r1 the init script has been renamed from precursor"
+ ewarn "to pdns-recursor, please update your runlevels accordingly."
+
+ break
+ done
+}
diff --git a/net-dns/pdns-recursor/pdns-recursor-4.5.7.ebuild b/net-dns/pdns-recursor/pdns-recursor-4.5.7.ebuild
new file mode 100644
index 000000000000..391869be2aec
--- /dev/null
+++ b/net-dns/pdns-recursor/pdns-recursor-4.5.7.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit flag-o-matic lua-single
+
+DESCRIPTION="The PowerDNS Recursor"
+HOMEPAGE="https://www.powerdns.com/"
+SRC_URI="https://downloads.powerdns.com/releases/${P/_/-}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug dnstap snmp sodium systemd test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+DEPEND="${LUA_DEPS}
+ dnstap? ( dev-libs/fstrm )
+ systemd? ( sys-apps/systemd:0= )
+ snmp? ( net-analyzer/net-snmp )
+ sodium? ( dev-libs/libsodium:= )
+ dev-libs/openssl:=
+ >=dev-libs/boost-1.35:="
+RDEPEND="${DEPEND}
+ !<net-dns/pdns-2.9.20-r1
+ acct-user/pdns
+ acct-group/pdns"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}"/${P/_/-}
+
+pkg_setup() {
+ lua-single_pkg_setup
+ filter-flags -ftree-vectorize
+}
+
+src_configure() {
+ econf \
+ --sysconfdir=/etc/powerdns \
+ --with-nod-cache-dir=/var/lib/powerdns \
+ --with-service-user=pdns \
+ --with-service-group=pdns \
+ --with-lua="${ELUA}" \
+ $(use_enable debug verbose-logging) \
+ $(use_enable systemd) \
+ $(use_enable dnstap dnstap) \
+ $(use_enable test unit-tests) \
+ $(use_with sodium libsodium) \
+ $(use_with snmp net-snmp)
+}
+
+src_install() {
+ default
+
+ mv "${D}"/etc/powerdns/recursor.conf{-dist,}
+
+ # set defaults: setuid=nobody, setgid=nobody
+ sed -i \
+ -e 's/^# set\([ug]\)id=$/set\1id=pdns/' \
+ -e 's/^# quiet=$/quiet=on/' \
+ -e 's/^# chroot=$/chroot=\/var\/lib\/powerdns/' \
+ "${D}"/etc/powerdns/recursor.conf
+
+ newinitd "${FILESDIR}"/pdns-recursor-r2 pdns-recursor
+}
+
+pkg_postinst() {
+ local old
+
+ for old in ${REPLACING_VERSIONS}; do
+ ver_test ${old} -lt 4.0.0-r1 || continue
+
+ ewarn "Starting with 4.0.0-r1 the init script has been renamed from precursor"
+ ewarn "to pdns-recursor, please update your runlevels accordingly."
+
+ break
+ done
+}