summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/dnsmasq/Manifest1
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.79.ebuild198
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.80.ebuild208
3 files changed, 0 insertions, 407 deletions
diff --git a/net-dns/dnsmasq/Manifest b/net-dns/dnsmasq/Manifest
index 328fffce268f..a01ccab43f47 100644
--- a/net-dns/dnsmasq/Manifest
+++ b/net-dns/dnsmasq/Manifest
@@ -1,2 +1 @@
-DIST dnsmasq-2.79.tar.xz 493036 BLAKE2B 91152c52aef06def74151f6fbae9153d25261ba5e6a728cbab503c074967963e40dce39d93a0fbe4c5497c9313ac24d495cc8233934c00d4ab82aefe83b01ccd SHA512 2c06212696ab55e1584f6133872f5b196013509e4b1822d0457787b456e14341afdde887749e370a2e512124cb4138f012f4601b08690707be4acc7cf2f2876f
DIST dnsmasq-2.80.tar.xz 501072 BLAKE2B 39c9808df43a22e32286105c9e001b2f817a4f68b92b84282eeb8cfeaa61404d64275bbb3f944bec6fac1b015987fba6aeab7a88201446c0cff67f02c8d88d8c SHA512 58e56beb553fc41311e5dc16d8b0eb3b6801e2bdfbcd0e7a6659703f08960b6ad10d48b0b14a4d727636faf35483e01597cff2ae49e7fe9fa9e214f437b1c068
diff --git a/net-dns/dnsmasq/dnsmasq-2.79.ebuild b/net-dns/dnsmasq/dnsmasq-2.79.ebuild
deleted file mode 100644
index c82ca7f79b3c..000000000000
--- a/net-dns/dnsmasq/dnsmasq-2.79.ebuild
+++ /dev/null
@@ -1,198 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs flag-o-matic user systemd
-
-DESCRIPTION="Small forwarding DNS server"
-HOMEPAGE="http://www.thekelleys.org.uk/dnsmasq/doc.html"
-SRC_URI="http://www.thekelleys.org.uk/dnsmasq/${P}.tar.xz"
-
-LICENSE="|| ( GPL-2 GPL-3 )"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86"
-
-IUSE="auth-dns conntrack dbus +dhcp dhcp-tools dnssec id idn libidn2 +inotify"
-IUSE+=" ipv6 lua nls script selinux static tftp"
-
-DM_LINGUAS=(de es fi fr id it no pl pt_BR ro)
-
-CDEPEND="dbus? ( sys-apps/dbus )
- idn? (
- !libidn2? ( net-dns/libidn:0 )
- libidn2? ( >=net-dns/libidn2-2.0 )
- )
- lua? ( dev-lang/lua:* )
- conntrack? ( net-libs/libnetfilter_conntrack )
- nls? ( sys-devel/gettext )
-"
-
-DEPEND="${CDEPEND}
- app-arch/xz-utils
- dnssec? (
- dev-libs/nettle[gmp]
- static? ( dev-libs/nettle[static-libs(+)] )
- )
- virtual/pkgconfig
-"
-
-RDEPEND="${CDEPEND}
- dnssec? (
- !static? (
- dev-libs/nettle[gmp]
- )
- )
- selinux? ( sec-policy/selinux-dnsmasq )
-"
-
-REQUIRED_USE="dhcp-tools? ( dhcp )
- lua? ( script )
- libidn2? ( idn )"
-
-use_have() {
- local useflag no_only uword
- if [[ $1 == '-n' ]]; then
- no_only=1
- shift
- fi
- useflag="${1}"
- shift
-
- uword="${1:-${useflag}}"
- shift
-
- while [[ ${uword} ]]; do
- uword="${uword^^}"
-
- if ! use "${useflag}"; then
- printf -- " -DNO_%s" "${uword}"
- elif [[ -z "${no_only}" ]]; then
- printf -- " -DHAVE_%s" "${uword}"
- fi
- uword="${1}"
- shift
- done
-}
-
-pkg_pretend() {
- if use static; then
- einfo "Only sys-libs/gmp and dev-libs/nettle are statically linked."
- use dnssec || einfo "Thus, ${P}[!dnssec,static] makes no sense; the static USE flag is ignored."
- fi
-}
-
-pkg_setup() {
- enewgroup dnsmasq
- enewuser dnsmasq -1 -1 /dev/null dnsmasq
-}
-
-src_prepare() {
- default
-
- sed -i -r 's:lua5.[0-9]+:lua:' Makefile
- sed -i "s:%%PREFIX%%:${EPREFIX}/usr:" dnsmasq.conf.example
-}
-
-src_configure() {
- COPTS="$(use_have -n auth-dns auth)"
- COPTS+="$(use_have conntrack)"
- COPTS+="$(use_have dbus)"
- COPTS+="$(use libidn2 || use_have idn)"
- COPTS+="$(use_have libidn2)"
- COPTS+="$(use_have -n inotify)"
- COPTS+="$(use_have -n dhcp dhcp dhcp6)"
- COPTS+="$(use_have -n ipv6 ipv6 dhcp6)"
- COPTS+="$(use_have -n id id)"
- COPTS+="$(use_have lua luascript)"
- COPTS+="$(use_have -n script)"
- COPTS+="$(use_have -n tftp)"
- COPTS+="$(use_have dnssec)"
- COPTS+="$(use_have static dnssec_static)"
-}
-
-src_compile() {
- emake \
- PREFIX=/usr \
- MANDIR=/usr/share/man \
- CC="$(tc-getCC)" \
- PKG_CONFIG="$(tc-getPKG_CONFIG)" \
- CFLAGS="${CFLAGS}" \
- LDFLAGS="${LDFLAGS}" \
- COPTS="${COPTS}" \
- CONFFILE="/etc/${PN}.conf" \
- all$(use nls && echo "-i18n")
-
- use dhcp-tools && emake -C contrib/lease-tools \
- PREFIX=/usr \
- MANDIR=/usr/share/man \
- CC="$(tc-getCC)" \
- PKG_CONFIG="$(tc-getPKG_CONFIG)" \
- CFLAGS="${CFLAGS}" \
- LDFLAGS="${LDFLAGS}" \
- all
-}
-
-src_install() {
- local lingua puid
- emake \
- PREFIX=/usr \
- MANDIR=/usr/share/man \
- COPTS="${COPTS}" \
- DESTDIR="${D}" \
- install$(use nls && echo "-i18n")
-
- for lingua in "${DM_LINGUAS[@]}"; do
- has ${lingua} ${LINGUAS-${lingua}} \
- || rm -rf "${D}"/usr/share/locale/${lingua}
- done
- [[ -d "${D}"/usr/share/locale/ ]] && rmdir --ignore-fail-on-non-empty "${D}"/usr/share/locale/
-
- dodoc CHANGELOG CHANGELOG.archive FAQ dnsmasq.conf.example
- dodoc -r logo
-
- docinto html/
- dodoc *.html
-
- newinitd "${FILESDIR}"/dnsmasq-init-r4 ${PN}
- newconfd "${FILESDIR}"/dnsmasq.confd-r1 ${PN}
-
- insinto /etc/logrotate.d
- newins "${FILESDIR}"/dnsmasq.logrotate ${PN}
-
- insinto /etc
- newins dnsmasq.conf.example dnsmasq.conf
-
- insinto /usr/share/dnsmasq
- doins trust-anchors.conf
-
- if use dhcp; then
- keepdir /var/lib/misc
- newinitd "${FILESDIR}"/dnsmasq-init-dhcp-r3 ${PN}
- fi
- if use dbus; then
- insinto /etc/dbus-1/system.d
- doins dbus/dnsmasq.conf
- fi
-
- if use dhcp-tools; then
- dosbin contrib/lease-tools/{dhcp_release,dhcp_lease_time}
- doman contrib/lease-tools/{dhcp_release,dhcp_lease_time}.1
- if use ipv6; then
- dosbin contrib/lease-tools/dhcp_release6
- doman contrib/lease-tools/dhcp_release6.1
- fi
- fi
-
- systemd_newunit "${FILESDIR}"/${PN}.service-r1 ${PN}.service
-}
-
-pkg_preinst() {
- # temporary workaround to (hopefully) prevent leases file from being removed
- [[ -f /var/lib/misc/dnsmasq.leases ]] && cp /var/lib/misc/dnsmasq.leases "${T}"
-}
-
-pkg_postinst() {
- # temporary workaround to (hopefully) prevent leases file from being removed
- [[ -f "${T}"/dnsmasq.leases ]] && cp "${T}"/dnsmasq.leases /var/lib/misc/dnsmasq.leases
-}
diff --git a/net-dns/dnsmasq/dnsmasq-2.80.ebuild b/net-dns/dnsmasq/dnsmasq-2.80.ebuild
deleted file mode 100644
index fbf773ea07c1..000000000000
--- a/net-dns/dnsmasq/dnsmasq-2.80.ebuild
+++ /dev/null
@@ -1,208 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs flag-o-matic user systemd
-
-DESCRIPTION="Small forwarding DNS server"
-HOMEPAGE="http://www.thekelleys.org.uk/dnsmasq/doc.html"
-SRC_URI="http://www.thekelleys.org.uk/dnsmasq/${P}.tar.xz"
-
-LICENSE="|| ( GPL-2 GPL-3 )"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86"
-
-IUSE="auth-dns conntrack dbus +dhcp dhcp-tools dnssec +dumpfile id idn libidn2"
-IUSE+=" +inotify ipv6 lua nls script selinux static tftp"
-
-DM_LINGUAS=(de es fi fr id it no pl pt_BR ro)
-
-BDEPEND="app-arch/xz-utils
- virtual/pkgconfig
- nls? ( sys-devel/gettext )
-"
-
-COMMON_DEPEND="dbus? ( sys-apps/dbus:= )
- idn? (
- !libidn2? ( net-dns/libidn:0= )
- libidn2? ( >=net-dns/libidn2-2.0:= )
- )
- lua? ( dev-lang/lua:* )
- conntrack? ( net-libs/libnetfilter_conntrack:= )
- nls? ( sys-devel/gettext )
-"
-
-DEPEND="${COMMON_DEPEND}
- dnssec? (
- dev-libs/nettle:=[gmp]
- static? ( >=dev-libs/nettle-3.4[static-libs(+)] )
- )
-"
-
-RDEPEND="${COMMON_DEPEND}
- dnssec? (
- !static? (
- >=dev-libs/nettle-3.4:=[gmp]
- )
- )
- selinux? ( sec-policy/selinux-dnsmasq )
-"
-
-REQUIRED_USE="dhcp-tools? ( dhcp )
- lua? ( script )
- libidn2? ( idn )"
-
-use_have() {
- local useflag no_only uword
- if [[ ${1} == '-n' ]]; then
- no_only=1
- shift
- fi
- useflag="${1}"
- shift
-
- uword="${1:-${useflag}}"
- shift
-
- while [[ ${uword} ]]; do
- uword="${uword^^}"
-
- if ! use "${useflag}"; then
- printf -- " -DNO_%s" "${uword}"
- elif [[ -z "${no_only}" ]]; then
- printf -- " -DHAVE_%s" "${uword}"
- fi
- uword="${1}"
- shift
- done
-}
-
-pkg_pretend() {
- if use static; then
- einfo "Only sys-libs/gmp and dev-libs/nettle are statically linked."
- use dnssec || einfo "Thus, ${P}[!dnssec,static] makes no sense;" \
- "the static USE flag is ignored."
- fi
-}
-
-pkg_setup() {
- enewgroup dnsmasq
- enewuser dnsmasq -1 -1 /dev/null dnsmasq
-}
-
-src_prepare() {
- default
-
- sed -i -r 's:lua5.[0-9]+:lua:' Makefile
- sed -i "s:%%PREFIX%%:${EPREFIX}/usr:" dnsmasq.conf.example
-}
-
-src_configure() {
- COPTS=(
- "$(use_have -n auth-dns auth)"
- "$(use_have conntrack)"
- "$(use_have dbus)"
- "$(use libidn2 || use_have idn)"
- "$(use_have libidn2)"
- "$(use_have -n inotify)"
- "$(use_have -n dhcp dhcp dhcp6)"
- "$(use_have -n ipv6 ipv6 dhcp6)"
- "$(use_have -n id id)"
- "$(use_have lua luascript)"
- "$(use_have -n script)"
- "$(use_have -n tftp)"
- "$(use_have dnssec)"
- "$(use_have static dnssec_static)"
- "$(use_have -n dumpfile)"
- )
-}
-
-src_compile() {
- emake \
- PREFIX=/usr \
- MANDIR=/usr/share/man \
- CC="$(tc-getCC)" \
- PKG_CONFIG="$(tc-getPKG_CONFIG)" \
- CFLAGS="${CFLAGS}" \
- LDFLAGS="${LDFLAGS}" \
- COPTS="${COPTS[*]}" \
- CONFFILE="/etc/${PN}.conf" \
- all$(use nls && printf -- "-i18n\n")
-
- use dhcp-tools && emake -C contrib/lease-tools \
- PREFIX=/usr \
- MANDIR=/usr/share/man \
- CC="$(tc-getCC)" \
- PKG_CONFIG="$(tc-getPKG_CONFIG)" \
- CFLAGS="${CFLAGS}" \
- LDFLAGS="${LDFLAGS}" \
- all
-}
-
-src_install() {
- local lingua puid
- emake \
- PREFIX=/usr \
- MANDIR=/usr/share/man \
- COPTS="${COPTS[*]}" \
- DESTDIR="${ED}" \
- install$(use nls && printf -- "-i18n\n")
-
- for lingua in "${DM_LINGUAS[@]}"; do
- has ${lingua} ${LINGUAS-${lingua}} \
- || rm -rf "${ED}"/usr/share/locale/${lingua}
- done
- [[ -d "${D}"/usr/share/locale/ ]] && \
- rmdir --ignore-fail-on-non-empty "${ED}"/usr/share/locale/
-
- dodoc CHANGELOG CHANGELOG.archive FAQ dnsmasq.conf.example
- dodoc -r logo
-
- docinto html/
- dodoc *.html
-
- newinitd "${FILESDIR}"/dnsmasq-init-r4 ${PN}
- newconfd "${FILESDIR}"/dnsmasq.confd-r1 ${PN}
-
- insinto /etc/logrotate.d
- newins "${FILESDIR}"/dnsmasq.logrotate ${PN}
-
- insinto /etc
- newins dnsmasq.conf.example dnsmasq.conf
-
- insinto /usr/share/dnsmasq
- doins trust-anchors.conf
-
- if use dhcp; then
- keepdir /var/lib/misc
- newinitd "${FILESDIR}"/dnsmasq-init-dhcp-r3 ${PN}
- fi
- if use dbus; then
- insinto /etc/dbus-1/system.d
- doins dbus/dnsmasq.conf
- fi
-
- if use dhcp-tools; then
- dosbin contrib/lease-tools/{dhcp_release,dhcp_lease_time}
- doman contrib/lease-tools/{dhcp_release,dhcp_lease_time}.1
- if use ipv6; then
- dosbin contrib/lease-tools/dhcp_release6
- doman contrib/lease-tools/dhcp_release6.1
- fi
- fi
-
- systemd_newunit "${FILESDIR}"/${PN}.service-r1 ${PN}.service
-}
-
-pkg_preinst() {
- # temporary workaround to (hopefully) prevent leases file from being removed
- [[ -f /var/lib/misc/dnsmasq.leases ]] && \
- cp /var/lib/misc/dnsmasq.leases "${T}"
-}
-
-pkg_postinst() {
- # temporary workaround to (hopefully) prevent leases file from being removed
- [[ -f "${T}"/dnsmasq.leases ]] && \
- cp "${T}"/dnsmasq.leases /var/lib/misc/dnsmasq.leases
-}