summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-firewall/nftables/files/nftables-0.5-pdf-doc.patch')
-rw-r--r--net-firewall/nftables/files/nftables-0.5-pdf-doc.patch22
1 files changed, 11 insertions, 11 deletions
diff --git a/net-firewall/nftables/files/nftables-0.5-pdf-doc.patch b/net-firewall/nftables/files/nftables-0.5-pdf-doc.patch
index b6f7834f920e..d09faa3ddd9f 100644
--- a/net-firewall/nftables/files/nftables-0.5-pdf-doc.patch
+++ b/net-firewall/nftables/files/nftables-0.5-pdf-doc.patch
@@ -4,22 +4,22 @@ generation.
--- a/configure.ac
+++ b/configure.ac
@@ -27,10 +27,16 @@
- AS_IF([test "x$enable_debug" = "xno"], [with_debug=no], [with_debug=yes]),
- [with_debug=yes])
- AC_SUBST(with_debug)
- AM_CONDITIONAL([BUILD_DEBUG], [test "x$with_debug" != xno])
+ AC_CONFIG_HEADER([config.h])
+
+ AC_DEFINE([_GNU_SOURCE], [], [Enable various GNU extensions])
+ AC_DEFINE([_STDC_FORMAT_MACROS], [], [printf-style format macros])
+AC_ARG_ENABLE([pdf-doc],
-+ AS_HELP_STRING([--enable-pdf-doc], [Enable PDF documentation]),
++ AS_HELP_STRING([--disable-pdf-doc], [Disable PDF documentation]),
+ AS_IF([test "x$enable_pdf_doc" = "xno"], [enable_pdf_doc=no],
-+ [enable_pdf_doc=yes]), [enable_pdf_doc=no])
++ [enable_pdf_doc=yes]), [enable_pdf_doc=yes])
+AM_CONDITIONAL([BUILD_PDF], [test "x$enable_pdf_doc" == "xyes" ])
+
- # Checks for programs.
- AC_PROG_CC
- AC_PROG_MKDIR_P
- AC_PROG_INSTALL
- AC_PROG_SED
+ AC_ARG_ENABLE([debug],
+ AS_HELP_STRING([--enable-debug], [Disable debugging]),
+ AS_IF([test "x$enable_debug" = "xno"], [with_debug=no], [with_debug=yes]),
+ [with_debug=yes])
+ AC_SUBST(with_debug)
@@ -61,15 +67,15 @@
)]
)