summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-firewall/nftlb/files')
-rw-r--r--net-firewall/nftlb/files/nftlb-1.0.8-musl.patch73
-rw-r--r--net-firewall/nftlb/files/nftlb-1.0.8-tests.patch45
2 files changed, 118 insertions, 0 deletions
diff --git a/net-firewall/nftlb/files/nftlb-1.0.8-musl.patch b/net-firewall/nftlb/files/nftlb-1.0.8-musl.patch
new file mode 100644
index 000000000000..75e84b14629b
--- /dev/null
+++ b/net-firewall/nftlb/files/nftlb-1.0.8-musl.patch
@@ -0,0 +1,73 @@
+diff --git a/configure.ac b/configure.ac
+index 8ec1711..1de7be7 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -2,6 +2,7 @@ AC_INIT([nftlb], [1.0.8], [netfilter-devel@vger.kernel.org])
+
+ AC_CONFIG_AUX_DIR([build-aux])
+ AC_CONFIG_MACRO_DIR([m4])
++AC_CONFIG_HEADERS([config.h])
+ AM_INIT_AUTOMAKE([-Wall foreign subdir-objects
+ tar-pax no-dist-gzip dist-bzip2 1.6])
+
+@@ -25,5 +26,7 @@ AC_CHECK_HEADER([ev.h], [EVENTINC="-include ev.h"],
+ [EVENTINC="-include libev/ev.h"],
+ [AC_MSG_ERROR([ev.h not found])])])
+
++AC_CHECK_HEADERS([execinfo.h])
++
+ AC_CONFIG_FILES([Makefile src/Makefile])
+ AC_OUTPUT
+diff --git a/src/main.c b/src/main.c
+index 2149e34..9ff3f7b 100644
+--- a/src/main.c
++++ b/src/main.c
+@@ -18,6 +18,7 @@
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ *
+ */
++#include "config.h"
+
+ #include <stdio.h>
+ #include <stdlib.h>
+@@ -25,6 +26,10 @@
+ #include <errno.h>
+ #include <unistd.h>
+
++#ifdef HAVE_EXECINFO_H
++ #include <execinfo.h>
++#endif /* HAVE_EXECINFO_H */
++
+ #include "config.h"
+ #include "objects.h"
+ #include "server.h"
+@@ -88,6 +93,7 @@ static void nftlb_sighandler(int signo)
+ exit(EXIT_SUCCESS);
+ }
+
++#ifdef HAVE_EXECINFO_H
+ static void nftlb_trace() {
+ int level;
+
+@@ -100,6 +106,7 @@ static void nftlb_trace() {
+ if (!obj_recovery())
+ exit(EXIT_FAILURE);
+ }
++#endif /* HAVE_EXECINFO_H */
+
+ static int main_process(const char *config, int mode)
+ {
+@@ -189,9 +196,13 @@ int main(int argc, char *argv[])
+
+ if (signal(SIGINT, nftlb_sighandler) == SIG_ERR ||
+ signal(SIGTERM, nftlb_sighandler) == SIG_ERR ||
++#ifdef HAVE_EXECINFO_H
+ signal(SIGPIPE, SIG_IGN) == SIG_ERR ||
+ signal(SIGABRT, nftlb_trace) == SIG_ERR ||
+ signal(SIGSEGV, nftlb_trace) == SIG_ERR) {
++#else
++ signal(SIGPIPE, SIG_IGN) == SIG_ERR) {
++#endif /* HAVE_EXECINFO_H */
+ zcu_log_print(LOG_ERR, "Error assigning signals");
+ return EXIT_FAILURE;
+ }
diff --git a/net-firewall/nftlb/files/nftlb-1.0.8-tests.patch b/net-firewall/nftlb/files/nftlb-1.0.8-tests.patch
new file mode 100644
index 000000000000..2eed096cad15
--- /dev/null
+++ b/net-firewall/nftlb/files/nftlb-1.0.8-tests.patch
@@ -0,0 +1,45 @@
+diff --git a/tests/config_exec/exec_tests.sh b/tests/config_exec/exec_tests.sh
+index f63950e..a55b467 100755
+--- a/tests/config_exec/exec_tests.sh
++++ b/tests/config_exec/exec_tests.sh
+@@ -36,6 +36,8 @@ fi
+
+ echo "-- Executing configuration tests"
+
++retval=0
++
+ for test in `ls -d ${TESTS}`; do
+ if [[ ! ${test} =~ ^..._ ]]; then
+ continue;
+@@ -58,6 +60,7 @@ for test in `ls -d ${TESTS}`; do
+
+ if [ $statusexec -ne 0 ]; then
+ echo -e "\e[31mNFT EXEC ERROR\e[0m"
++ retval=1
+ continue;
+ fi
+
+@@ -65,6 +68,7 @@ for test in `ls -d ${TESTS}`; do
+
+ if [ ! -f ${outputfile} ]; then
+ echo "Dump file doesn't exist"
++ retval=1
+ continue;
+ fi
+
+@@ -76,6 +80,7 @@ for test in `ls -d ${TESTS}`; do
+ rm -f ${reportfile}
+ else
+ echo -e "\e[31mNFT DUMP ERROR\e[0m"
++ retval=1
+ if [ $APPLY_REPORTS -eq 1 ]; then
+ cat ${reportfile} > ${outputfile}
+ echo -e "APPLIED"
+@@ -89,4 +94,7 @@ fi
+
+ if [ "`grep 'nft command error' /var/log/syslog`" != "" ]; then
+ echo -e "\e[33m* command errors found, please check syslog\e[0m"
++ retval=1
+ fi
++
++exit ${retval}