summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-firewall/rtsp-conntrack/rtsp-conntrack-3.7.ebuild')
-rw-r--r--net-firewall/rtsp-conntrack/rtsp-conntrack-3.7.ebuild17
1 files changed, 5 insertions, 12 deletions
diff --git a/net-firewall/rtsp-conntrack/rtsp-conntrack-3.7.ebuild b/net-firewall/rtsp-conntrack/rtsp-conntrack-3.7.ebuild
index 51d0c0cf892b..14fb40edd823 100644
--- a/net-firewall/rtsp-conntrack/rtsp-conntrack-3.7.ebuild
+++ b/net-firewall/rtsp-conntrack/rtsp-conntrack-3.7.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils linux-mod versionator
+EAPI=7
+inherit linux-mod
DESCRIPTION="RTSP conntrack module for Netfilter"
HOMEPAGE="http://mike.it-loops.com/rtsp"
@@ -14,6 +14,8 @@ KEYWORDS="amd64 x86"
S="${WORKDIR}/rtsp"
+PATCHES=( "${FILESDIR}/${P}-linux-4.18.patch" )
+
BUILD_TARGETS="all"
MODULE_NAMES="
nf_conntrack_rtsp(net/netfilter::)
@@ -24,12 +26,3 @@ CONFIG_CHECK="NF_CONNTRACK"
WARNING_NF_CONNTRACK="You must enable NF_CONNTRACK in your kernel, otherwise ${PN} would not work"
BUILD_PARAMS="KERNELDIR=${KERNEL_DIR} V=1"
-
-pkg_setup() {
- linux-mod_pkg_setup
- kernel_is -lt $(get_version_components) && die "This version of ${PN} would not work on kernels <= ${PV}"
-}
-
-src_prepare() {
- epatch_user
-}