summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/fwknop/Manifest1
-rw-r--r--net-firewall/fwknop/fwknop-2.6.7-r2.ebuild131
-rw-r--r--net-firewall/fwknop/fwknop-2.6.8.ebuild131
3 files changed, 0 insertions, 263 deletions
diff --git a/net-firewall/fwknop/Manifest b/net-firewall/fwknop/Manifest
index d7709562e818..7237b4578a70 100644
--- a/net-firewall/fwknop/Manifest
+++ b/net-firewall/fwknop/Manifest
@@ -1,2 +1 @@
-DIST fwknop-2.6.7.tar.gz 2849006 SHA256 e96c13f725a4c3829c842743b14aedf591d30570df5c06556862a900b64def86 SHA512 8a8c5e76740c495342fd914309de564576ce5c7fda90dc0f0322782ace5f28ccbb4bcef4c0a3353a564b13ef7298a5cd75dcd4d26986b2fb5ec000b641fbf848 WHIRLPOOL 6de45c31cc39b7b44d0531dc19bd2727bc721cf156a04d830c295573fe40d95296c1591e3bd5ae2b597bea9a6015744061351655f1cf04a5d6a5cae6678d1126
DIST fwknop-2.6.8.tar.gz 2860231 SHA256 96e6ba8b7e29aaf65bd06eaa823896ab66169b2aaced8123375378ff4b76a2d6 SHA512 aed4081652a95f3276468d58476d093a6dd76abbe5b4047930fc32a0d46f3dc341a3b0d9b7c81dc6c466f468f06c94607f2dadc89867127d0b4878175e32b6d6 WHIRLPOOL d394b43c5eb96a4172ec005dc8ec13985e8b70bd342eabfdd95d0fd7a6425ddc294d24900f6b85b4ce7c595cf45622b28ee08583fb222c7d5d9f74f87a10c1cc
diff --git a/net-firewall/fwknop/fwknop-2.6.7-r2.ebuild b/net-firewall/fwknop/fwknop-2.6.7-r2.ebuild
deleted file mode 100644
index 582a81b605dd..000000000000
--- a/net-firewall/fwknop/fwknop-2.6.7-r2.ebuild
+++ /dev/null
@@ -1,131 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-AUTOTOOLS_AUTORECONF=1
-AUTOTOOLS_IN_SOURCE_BUILD=1
-DISABLE_AUTOFORMATTING=1
-
-DISTUTILS_OPTIONAL=1
-# Python extension supports only Python2
-# See https://github.com/mrash/fwknop/issues/167
-PYTHON_COMPAT=( python2_7 )
-
-inherit autotools-utils distutils-r1 linux-info readme.gentoo systemd
-
-DESCRIPTION="Single Packet Authorization and Port Knocking application"
-HOMEPAGE="http://www.cipherdyne.org/fwknop/ https://github.com/mrash/fwknop"
-SRC_URI="https://github.com/mrash/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="client extras firewalld gdbm gpg iptables python server udp-server"
-
-DEPEND="
- client? ( net-misc/wget[ssl] )
- firewalld? ( net-firewall/firewalld[${PYTHON_USEDEP}] )
- gdbm? ( sys-libs/gdbm )
- gpg? (
- app-crypt/gpgme
- dev-libs/libassuan
- dev-libs/libgpg-error
- )
- iptables? ( net-firewall/iptables )
- python? ( ${PYTHON_DEPS} )
- server? ( !udp-server? ( net-libs/libpcap ) )
-"
-RDEPEND="${DEPEND}"
-
-REQUIRED_USE="
- python? ( ${PYTHON_REQUIRED_USE} )
- firewalld? ( server )
- iptables? ( server )
- server? ( ^^ ( firewalld iptables ) )
- udp-server? ( server )
-"
-
-DOCS=( ChangeLog README.md )
-
-DOC_CONTENTS="
-Example configuration files were installed in /etc/fwknopd directory.
-Please edit them to fit your needs and then remove the .example suffix.
-
-fwknopd supports several backends: firewalld, iptables, ipfw, pf, ipf.
-You can set the desired backend via FIREWALL_EXE option in fwknopd.conf
-instead of the default one chosen at compile time.
-"
-
-pkg_pretend() {
- if use server; then
- if ! linux_config_exists || ! linux_chkconfig_present NETFILTER_XT_MATCH_COMMENT; then
- ewarn "fwknopd uses the iptables 'comment' match to expire SPA rules,"
- ewarn "which is a major security feature and is enabled by default."
- ewarn "Please either enable NETFILTER_XT_MATCH_COMMENT support in your"
- ewarn "kernel, or set the appropriate ENABLE_{FIREWD,IPT}_COMMENT_CHECK"
- ewarn "to 'N' in your fwknopd.conf file."
- fi
- fi
-}
-
-src_prepare() {
- # Install example configs with .example suffix
- if use server; then
- sed -i -e 's/conf;/conf.example;/g' "${S}"/Makefile.am || die
- fi
-
- autotools-utils_src_prepare
-}
-
-src_configure() {
- local myeconfargs=(
- --localstatedir=/run
- --enable-digest-cache
- $(use_enable client)
- $(use_enable !gdbm file-cache)
- $(use_enable server)
- $(use_enable udp-server)
- $(use_with gpg gpgme)
- )
- use firewalld && myeconfargs+=(--with-firewalld=/usr/sbin/firewalld)
- use iptables && myeconfargs+=(--with-iptables=/sbin/iptables)
-
- autotools-utils_src_configure
-}
-
-src_compile() {
- autotools-utils_src_compile
-
- if use python; then
- cd "${S}"/python || die
- distutils-r1_src_compile
- fi
-}
-
-src_install() {
- autotools-utils_src_install
- prune_libtool_files --modules
-
- if use server; then
- newinitd "${FILESDIR}/fwknopd.init" fwknopd
- newconfd "${FILESDIR}/fwknopd.confd" fwknopd
- systemd_dounit extras/systemd/fwknopd.service
- systemd_newtmpfilesd extras/systemd/fwknopd.tmpfiles.conf fwknopd.conf
- readme.gentoo_create_doc
- fi
-
- use extras && dodoc "${S}/extras/apparmor/usr.sbin.fwknopd"
-
- if use python; then
- # Unset DOCS since distutils-r1.eclass interferes
- local DOCS=()
- cd "${S}"/python || die
- distutils-r1_src_install
- fi
-}
-
-pkg_postinst() {
- use server && readme.gentoo_print_elog
-}
diff --git a/net-firewall/fwknop/fwknop-2.6.8.ebuild b/net-firewall/fwknop/fwknop-2.6.8.ebuild
deleted file mode 100644
index 582a81b605dd..000000000000
--- a/net-firewall/fwknop/fwknop-2.6.8.ebuild
+++ /dev/null
@@ -1,131 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-AUTOTOOLS_AUTORECONF=1
-AUTOTOOLS_IN_SOURCE_BUILD=1
-DISABLE_AUTOFORMATTING=1
-
-DISTUTILS_OPTIONAL=1
-# Python extension supports only Python2
-# See https://github.com/mrash/fwknop/issues/167
-PYTHON_COMPAT=( python2_7 )
-
-inherit autotools-utils distutils-r1 linux-info readme.gentoo systemd
-
-DESCRIPTION="Single Packet Authorization and Port Knocking application"
-HOMEPAGE="http://www.cipherdyne.org/fwknop/ https://github.com/mrash/fwknop"
-SRC_URI="https://github.com/mrash/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="client extras firewalld gdbm gpg iptables python server udp-server"
-
-DEPEND="
- client? ( net-misc/wget[ssl] )
- firewalld? ( net-firewall/firewalld[${PYTHON_USEDEP}] )
- gdbm? ( sys-libs/gdbm )
- gpg? (
- app-crypt/gpgme
- dev-libs/libassuan
- dev-libs/libgpg-error
- )
- iptables? ( net-firewall/iptables )
- python? ( ${PYTHON_DEPS} )
- server? ( !udp-server? ( net-libs/libpcap ) )
-"
-RDEPEND="${DEPEND}"
-
-REQUIRED_USE="
- python? ( ${PYTHON_REQUIRED_USE} )
- firewalld? ( server )
- iptables? ( server )
- server? ( ^^ ( firewalld iptables ) )
- udp-server? ( server )
-"
-
-DOCS=( ChangeLog README.md )
-
-DOC_CONTENTS="
-Example configuration files were installed in /etc/fwknopd directory.
-Please edit them to fit your needs and then remove the .example suffix.
-
-fwknopd supports several backends: firewalld, iptables, ipfw, pf, ipf.
-You can set the desired backend via FIREWALL_EXE option in fwknopd.conf
-instead of the default one chosen at compile time.
-"
-
-pkg_pretend() {
- if use server; then
- if ! linux_config_exists || ! linux_chkconfig_present NETFILTER_XT_MATCH_COMMENT; then
- ewarn "fwknopd uses the iptables 'comment' match to expire SPA rules,"
- ewarn "which is a major security feature and is enabled by default."
- ewarn "Please either enable NETFILTER_XT_MATCH_COMMENT support in your"
- ewarn "kernel, or set the appropriate ENABLE_{FIREWD,IPT}_COMMENT_CHECK"
- ewarn "to 'N' in your fwknopd.conf file."
- fi
- fi
-}
-
-src_prepare() {
- # Install example configs with .example suffix
- if use server; then
- sed -i -e 's/conf;/conf.example;/g' "${S}"/Makefile.am || die
- fi
-
- autotools-utils_src_prepare
-}
-
-src_configure() {
- local myeconfargs=(
- --localstatedir=/run
- --enable-digest-cache
- $(use_enable client)
- $(use_enable !gdbm file-cache)
- $(use_enable server)
- $(use_enable udp-server)
- $(use_with gpg gpgme)
- )
- use firewalld && myeconfargs+=(--with-firewalld=/usr/sbin/firewalld)
- use iptables && myeconfargs+=(--with-iptables=/sbin/iptables)
-
- autotools-utils_src_configure
-}
-
-src_compile() {
- autotools-utils_src_compile
-
- if use python; then
- cd "${S}"/python || die
- distutils-r1_src_compile
- fi
-}
-
-src_install() {
- autotools-utils_src_install
- prune_libtool_files --modules
-
- if use server; then
- newinitd "${FILESDIR}/fwknopd.init" fwknopd
- newconfd "${FILESDIR}/fwknopd.confd" fwknopd
- systemd_dounit extras/systemd/fwknopd.service
- systemd_newtmpfilesd extras/systemd/fwknopd.tmpfiles.conf fwknopd.conf
- readme.gentoo_create_doc
- fi
-
- use extras && dodoc "${S}/extras/apparmor/usr.sbin.fwknopd"
-
- if use python; then
- # Unset DOCS since distutils-r1.eclass interferes
- local DOCS=()
- cd "${S}"/python || die
- distutils-r1_src_install
- fi
-}
-
-pkg_postinst() {
- use server && readme.gentoo_print_elog
-}